aboutsummaryrefslogtreecommitdiffstats
path: root/ui/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2012-12-17 21:24:22 +0000
committerGerald Combs <gerald@wireshark.org>2012-12-17 21:24:22 +0000
commitdc908733eaf62b0a3506dca52f2412b92a6cbf7c (patch)
tree1e3896b1388b624ee5c0edb3894af734079dca73 /ui/CMakeLists.txt
parente3cc19d866f5dfe53411d42c8f70c39c6e09377c (diff)
Add libui_dirty.
svn path=/trunk/; revision=46575
Diffstat (limited to 'ui/CMakeLists.txt')
-rw-r--r--ui/CMakeLists.txt19
1 files changed, 14 insertions, 5 deletions
diff --git a/ui/CMakeLists.txt b/ui/CMakeLists.txt
index 003ccc3fc1..201bb7f738 100644
--- a/ui/CMakeLists.txt
+++ b/ui/CMakeLists.txt
@@ -35,17 +35,20 @@ set(COMMON_UI_SRC
util.c
)
-set(CLEAN_FILES
- ${COMMON_UI_SRC}
-)
+set(DIRTY_UI_SRC)
-add_lex_files(COMMON_UI_SRC
+add_lex_files(DIRTY_UI_SRC
text_import_scanner.l
)
+set(CLEAN_FILES
+ ${COMMON_UI_SRC}
+ ${DIRTY_UI_SRC}
+)
+
if (WERROR)
set_source_files_properties(
- ${CLEAN_FILES}
+ ${COMMON_UI_SRC}
PROPERTIES
COMPILE_FLAGS -Werror
)
@@ -57,3 +60,9 @@ add_library(ui STATIC
)
set_target_properties(ui PROPERTIES LINK_FLAGS "${WS_LINK_FLAGS}")
+
+add_library(ui_dirty STATIC
+ ${DIRTY_UI_SRC}
+)
+
+set_target_properties(ui_dirty PROPERTIES LINK_FLAGS "${WS_LINK_FLAGS}")