aboutsummaryrefslogtreecommitdiffstats
path: root/ui/CMakeLists.txt
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2018-02-16 18:22:31 -0800
committerGuy Harris <guy@alum.mit.edu>2018-02-17 02:50:24 +0000
commit459bd4646d15c56b14f9f10d86c6f5d342174c98 (patch)
tree31e71e4c72af3abe9806026a7c3cdc0a73340e85 /ui/CMakeLists.txt
parent5f0d50690ae01427ae310e15989cbe3780a241ad (diff)
Don't have CLEAN_FILES variables for the "clean" source files.
Except for the one directory that (currently) has "not yet clean" files, epan/dissectors, we don't need a separate variable to keep track of the "clean" source files. In the cases where not all files were in CLEAN_FILES, put them into the variable used to enable -Werror or its equivalent. Change-Id: Ic4119861c1d9e381adfe31e9977e1ac71d623f5b Reviewed-on: https://code.wireshark.org/review/25830 Petri-Dish: Guy Harris <guy@alum.mit.edu> Tested-by: Petri Dish Buildbot Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'ui/CMakeLists.txt')
-rw-r--r--ui/CMakeLists.txt27
1 files changed, 10 insertions, 17 deletions
diff --git a/ui/CMakeLists.txt b/ui/CMakeLists.txt
index ea78f7830c..6c4d2c6944 100644
--- a/ui/CMakeLists.txt
+++ b/ui/CMakeLists.txt
@@ -19,7 +19,7 @@
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
#
-set(COMMON_UI_SRC
+set(NONGENERATED_UI_SRC
alert_box.c
capture.c
capture_ui_utils.c
@@ -73,25 +73,20 @@ file(GLOB EXTRA_UI_HEADERS
tap-rtp-analysis.h
)
-add_lex_files(LEX_FILES GENERATED_FILES
- text_import_scanner.l
-)
+set(UI_SRC ${NONGENERATED_UI_SRC})
-set(CLEAN_FILES
- ${COMMON_UI_SRC}
+add_lex_files(LEX_FILES UI_SRC
+ text_import_scanner.l
)
set_source_files_properties(
- ${CLEAN_FILES}
+ ${UI_SRC}
PROPERTIES
COMPILE_FLAGS "${WERROR_COMMON_FLAGS}"
)
-add_library(ui STATIC
- ${COMMON_UI_SRC}
- ${GENERATED_FILES}
-)
+add_library(ui STATIC ${UI_SRC})
set_target_properties(ui PROPERTIES
LINK_FLAGS "${WS_LINK_FLAGS}"
@@ -115,9 +110,8 @@ CHECKAPI(
SWITCHES
-g deprecated-gtk
SOURCES
- ${COMMON_UI_SRC}
-# LEX files commented out due to use of malloc, free etc.
-# ${LEX_FILES}
+ ${NONGENERATED_UI_SRC}
+# Flex files not included due to use of malloc, free etc.
)
CHECKAPI(
NAME
@@ -125,9 +119,8 @@ CHECKAPI(
SWITCHES
-M -g deprecated-gtk-todo
SOURCES
- ${COMMON_UI_SRC}
-# LEX files commented out due to use of malloc, free etc.
-# ${LEX_FILES}
+ ${NONGENERATED_UI_SRC}
+# Flex files not included due to use of malloc, free etc.
)
#