aboutsummaryrefslogtreecommitdiffstats
path: root/tools/tpg/Makefile.am
diff options
context:
space:
mode:
authorLuis Ontanon <luis.ontanon@gmail.com>2005-09-27 20:48:48 +0000
committerLuis Ontanon <luis.ontanon@gmail.com>2005-09-27 20:48:48 +0000
commit72cbc6410b80e0ca8d8fc7fa5f7d49ea70c74398 (patch)
tree39da66825e2d2d6b506b9c604cde524df2b0451c /tools/tpg/Makefile.am
parent9a66525b71ff30396b80804406affa14de450e55 (diff)
TPG TVB Parser Generator
Given a bnf-like grammar generate a set of helpers for a dissector It's not working yet, however I need this checkin as a cheeckpoint (I'll write the doc when it starts to be ready) svn path=/trunk/; revision=16021
Diffstat (limited to 'tools/tpg/Makefile.am')
-rw-r--r--tools/tpg/Makefile.am50
1 files changed, 50 insertions, 0 deletions
diff --git a/tools/tpg/Makefile.am b/tools/tpg/Makefile.am
new file mode 100644
index 0000000000..e2a40f154d
--- /dev/null
+++ b/tools/tpg/Makefile.am
@@ -0,0 +1,50 @@
+# Makefile.am
+#
+# $Id$
+#
+# Ethereal - Network traffic analyzer
+# By Gerald Combs <gerald@zing.org>
+# Copyright 2001 Gerald Combs
+#
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
+# We produce an archive library. In the future, when libethereal is a
+# shared library, this will be linked into libethereal. While libethereal
+# is an archive library, any executable linking against libethereal will
+# also need to link against libftypes.
+
+CLEANFILES = \
+ *~
+
+MAINTAINERCLEANFILES = \
+ Makefile.in \
+ tpg.output \
+ TPG.pm
+
+EXTRA_DIST = \
+ tpg.yp \
+ V2P.pl \
+ TPG.pm \
+ tpg.pl \
+ Makefile.nmake \
+ README
+
+TPG.pm: tpg.yp
+ yapp -v -m TPG tpg.yp
+
+tpg.pl: TPG.pm
+
+all: tpg.pl