aboutsummaryrefslogtreecommitdiffstats
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2015-09-24 10:42:46 -0700
committerGerald Combs <gerald@wireshark.org>2015-09-25 20:04:42 +0000
commitff1dbba6ec981d32438235587c52ca4d0c039b0a (patch)
tree7b9e5059c6b52351ee8a5a1d7ebef54e5b913f44 /tools/Makefile.am
parent44d17c784483b1647500af1bb1afab58ca3295e2 (diff)
CMake: Add a hardening-check target.
On Windows, add a hardening-check target which checks for DYNAMICBASE and NXCOMPAT using the PowerShell script Get-HardenFlags.ps1. For a Visual Studio solution, run the check by calling: msbuild /m /p:Configuration=RelWithDebInfo hardening-check.vcxproj using the config as appropriate for your build. Otherwise if we find the Debian/Fedora hardening-check script add a target which runs it for each of our executables. Change-Id: I62263e81d155c66e8c8edc751ffab535bf9f3b96 Reviewed-on: https://code.wireshark.org/review/10641 Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index 5904ec723d..e6bbcea29d 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -132,12 +132,13 @@ EXTRA_DIST = \
dftestlib/util.py \
extract_asn1_from_spec.pl \
fix-encoding-args.pl \
- fix_pragma_wdocumentation.sh \
+ fix_pragma_wdocumentation.sh \
fixhf.pl \
ftsanity.py \
fuzz-test.sh \
gen-bugnote \
- generate-bacnet-vendors.py \
+ generate-bacnet-vendors.py \
+ Get-HardenFlags.ps1 \
git-compare-abis.sh \
git-export-release.sh \
html2text.py \
@@ -164,7 +165,7 @@ EXTRA_DIST = \
npl/npl.c \
npl/parser.l \
npl/xmem.h \
- parse_xml2skinny_dissector.py \
+ parse_xml2skinny_dissector.py \
pkt-from-core.py \
pre-commit \
process-x11-fields.pl \