aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/stats_tree/Makefile.am
diff options
context:
space:
mode:
authorLuis Ontanon <luis.ontanon@gmail.com>2005-02-16 14:26:27 +0000
committerLuis Ontanon <luis.ontanon@gmail.com>2005-02-16 14:26:27 +0000
commitf99b87c519a92feeb4fc7f66747ab742c7a8d94a (patch)
treedff29966b53b659fc7d3ad16cb3ad6f990d4054c /plugins/stats_tree/Makefile.am
parent43124c8744ef48be39b0ec3ec15092e402e73b1d (diff)
An example stats_tree plugin using pinfo as its only data source
I'm not checking changes to the Makefiles yet. svn path=/trunk/; revision=13415
Diffstat (limited to 'plugins/stats_tree/Makefile.am')
-rw-r--r--plugins/stats_tree/Makefile.am44
1 files changed, 44 insertions, 0 deletions
diff --git a/plugins/stats_tree/Makefile.am b/plugins/stats_tree/Makefile.am
new file mode 100644
index 0000000000..bd0aa9bd17
--- /dev/null
+++ b/plugins/stats_tree/Makefile.am
@@ -0,0 +1,44 @@
+# Makefile.am
+# Automake file for stats_tree Ethereal plugin
+#
+# $Id: Makefile.am 12763 2004-12-16 19:36:23Z lroland $
+#
+# Ethereal - Network traffic analyzer
+# By Gerald Combs <gerald@ethereal.com>
+# Copyright 1998 Gerald Combs
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+#
+
+INCLUDES = -I$(top_srcdir)
+
+plugindir = @plugindir@
+
+plugin_LTLIBRARIES = stats_tree.la
+stats_tree_la_SOURCES = pinfo_stats_tree.c stats_tree_plugin.c
+stats_tree_la_LDFLAGS = -module -avoid-version
+stats_tree_la_LIBADD = @PLUGIN_LIBS@
+
+# Libs must be cleared, or else libtool won't create a shared module.
+# If your module needs to be linked against any particular libraries,
+# add them here.
+LIBS =
+
+CLEANFILES = \
+ stats_tree \
+ *~
+
+EXTRA_DIST = \
+ Makefile.nmake