aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/docsis/Makefile.am
diff options
context:
space:
mode:
authorStephen Fisher <steve@stephen-fisher.com>2007-03-22 23:03:39 +0000
committerStephen Fisher <steve@stephen-fisher.com>2007-03-22 23:03:39 +0000
commitcdf47e536bc77c178a630f5bf474b7ba148394fd (patch)
tree29f085b19c89a9bba21ab7461a300809b9bfe12d /plugins/docsis/Makefile.am
parent7f3e4fea48dad56d9ecfb73aab614233cdde5a0e (diff)
Add -Werror when using GCC only to the Makefile.am of the base
directory and most of the plugins to match the same command put in the Makefile.nmake files for Windows compliations. Fix a few warnings when compiling under gcc 3.4.4 on FreeBSD. Create new automake file variable called USING_GCC in configure.in and wiretap/configure.in to acomplish the above -Werror addition. svn path=/trunk/; revision=21127
Diffstat (limited to 'plugins/docsis/Makefile.am')
-rw-r--r--plugins/docsis/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/plugins/docsis/Makefile.am b/plugins/docsis/Makefile.am
index a788f053c4..10816545c0 100644
--- a/plugins/docsis/Makefile.am
+++ b/plugins/docsis/Makefile.am
@@ -26,6 +26,10 @@ INCLUDES = -I$(top_srcdir) -I$(includedir)
include Makefile.common
+if USING_GCC
+AM_CFLAGS = -Werror
+endif
+
plugindir = @plugindir@
plugin_LTLIBRARIES = docsis.la