aboutsummaryrefslogtreecommitdiffstats
path: root/packaging/wix/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2019-02-27 16:20:01 -0800
committerGerald Combs <gerald@wireshark.org>2019-02-28 16:37:07 +0000
commita0c93f426b0bb3510af3e4657d95bd64e46ed5f8 (patch)
tree6e53f0be3e0ad86ed1b0e895322d3a0b556508b2 /packaging/wix/CMakeLists.txt
parent41c566b48d48d7f67c2936e56b6df765f0cbf488 (diff)
CMake: Don't build Windows package targets by default.
Explicitly exclude our various Windows package targets from the Visual Studio default build. This will hopefully keep the 32-bit Windows builder from trying to build the portableapps_runtime target when it shouldn't. Change-Id: Id8481e92abda9b1a4784b8c8e8b5a1b3f1b4647e Reviewed-on: https://code.wireshark.org/review/32256 Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'packaging/wix/CMakeLists.txt')
-rw-r--r--packaging/wix/CMakeLists.txt10
1 files changed, 8 insertions, 2 deletions
diff --git a/packaging/wix/CMakeLists.txt b/packaging/wix/CMakeLists.txt
index dd360e87ad..999cd54f1f 100644
--- a/packaging/wix/CMakeLists.txt
+++ b/packaging/wix/CMakeLists.txt
@@ -279,7 +279,10 @@ macro( ADD_WIX_PACKAGE_TARGET )
user_guide_chm
faq_html
)
- set_target_properties(wix_package_prep PROPERTIES FOLDER "Packaging")
+ set_target_properties(wix_package_prep PROPERTIES
+ FOLDER "Packaging"
+ EXCLUDE_FROM_DEFAULT_BUILD True
+ )
# Dump the installer into
# ${CMAKE_CURRENT_SOURCE_DIR}/packaging/wix
@@ -291,7 +294,10 @@ macro( ADD_WIX_PACKAGE_TARGET )
COMMAND ${WIX_LIGHT_EXECUTABLE} ${WIX_LIGHT_DEFINES} ${WIX_OUT_FILES}
WORKING_DIRECTORY ${_wix_binary_dir}
)
- set_target_properties(wix_package PROPERTIES FOLDER "Packaging")
+ set_target_properties(wix_package PROPERTIES
+ FOLDER "Packaging"
+ EXCLUDE_FROM_DEFAULT_BUILD True
+ )
else()
message(WARNING "The WiX installer cannot be built if the Wireshark program isn't built.")
endif()