aboutsummaryrefslogtreecommitdiffstats
path: root/fuzz/CMakeLists.txt
diff options
context:
space:
mode:
authorJoão Valverde <j@v6e.pt>2021-07-03 12:58:30 +0100
committerWireshark GitLab Utility <gerald+gitlab-utility@wireshark.org>2021-07-04 10:37:49 +0000
commit100876337af28f9e86259e0a17e28d1ea1b737a2 (patch)
treea366f31adae1393872c124b3fa8719f2d5cd0dd5 /fuzz/CMakeLists.txt
parent47d2afd99018b5ef85376e1ff81ee11af4483fa3 (diff)
Move version_info.[ch] to ui/
Version info is an aspect of UI implementation so move it to a more appropriate place, such as ui/. This also helps declutter the top-level. A static library is appropriate to encapsulate the dependencies as private and it is better supported by CMake than object libraries. Also version_info.h should not be installed as a public header.
Diffstat (limited to 'fuzz/CMakeLists.txt')
-rw-r--r--fuzz/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/fuzz/CMakeLists.txt b/fuzz/CMakeLists.txt
index 9e9598badc..c4229922b5 100644
--- a/fuzz/CMakeLists.txt
+++ b/fuzz/CMakeLists.txt
@@ -30,7 +30,7 @@ set(fuzzshark_LIBS
ui
wiretap
epan
- ${VERSION_INFO_LIBS}
+ version_info
)
if(OSS_FUZZ)
if("$ENV{LIB_FUZZING_ENGINE}" STREQUAL "")
@@ -40,7 +40,6 @@ if(OSS_FUZZ)
endif()
set(fuzzshark_FILES
fuzzshark.c
- $<TARGET_OBJECTS:version_info>
)
set(FUZZ_LINK_FLAGS "${WS_LINK_FLAGS}")
if(ENABLE_FUZZER)