aboutsummaryrefslogtreecommitdiffstats
path: root/extcap/Makefile.am
diff options
context:
space:
mode:
authorDario Lombardo <lomato@gmail.com>2018-04-15 23:40:36 +0200
committerAnders Broman <a.broman58@gmail.com>2018-04-18 03:46:17 +0000
commit4a156da068269aae75d79cd08e579754c52a0c43 (patch)
tree9637e57f0ceaaac66f6c47410c27054106d7d21a /extcap/Makefile.am
parent2e639570318018871e934fb7a397ba8a2bdcfbe8 (diff)
Remove autotools build system.
It has been replaced by cmake. Change-Id: I83a5eddb8645dbbf6bca9f026066d2e995d8e87a Reviewed-on: https://code.wireshark.org/review/26969 Petri-Dish: Dario Lombardo <lomato@gmail.com> Tested-by: Petri Dish Buildbot Reviewed-by: Gerald Combs <gerald@wireshark.org> Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'extcap/Makefile.am')
-rw-r--r--extcap/Makefile.am85
1 files changed, 0 insertions, 85 deletions
diff --git a/extcap/Makefile.am b/extcap/Makefile.am
deleted file mode 100644
index 6a4d7f39c7..0000000000
--- a/extcap/Makefile.am
+++ /dev/null
@@ -1,85 +0,0 @@
-# Makefile.am
-# Automake file for extcap tools
-#
-# Wireshark - Network traffic analyzer
-# By Gerald Combs <gerald@wireshark.org>
-# Copyright 1998 Gerald Combs
-#
-# SPDX-License-Identifier: GPL-2.0-or-later
-
-include ../Makefile.am.inc
-
-AM_CPPFLAGS = $(INCLUDEDIRS) $(WS_CPPFLAGS) $(GLIB_CFLAGS) $(PCAP_CFLAGS)
-
-EXTRA_DIST = \
- .editorconfig
-
-extcap_PROGRAMS = \
- @androiddump_bin@ \
- @randpktdump_bin@ \
- @sshdump_bin@ \
- @ciscodump_bin@ \
- @udpdump_bin@
-
-EXTRA_PROGRAMS = androiddump randpktdump sshdump ciscodump udpdump
-
-androiddump_SOURCES = \
- androiddump.c \
- extcap-base.c
-
-# Libraries and plugin flags with which to link androiddump.
-androiddump_LDADD = \
- ../ui/libui.a \
- ../wiretap/libwiretap.la \
- ../wsutil/libwsutil.la \
- @GLIB_LIBS@
-
-randpktdump_SOURCES = \
- randpktdump.c \
- extcap-base.c
-
-# Libraries and plugin flags with which to link randpktdump.
-randpktdump_LDADD = \
- ../randpkt_core/librandpkt_core.a \
- ../ui/libui.a \
- ../wiretap/libwiretap.la \
- ../wsutil/libwsutil.la \
- @GLIB_LIBS@
-
-sshdump_SOURCES = \
- sshdump.c \
- extcap-base.c \
- ssh-base.c
-
-# Libraries and plugin flags with which to link sshdump.
-sshdump_LDADD = \
- ../wiretap/libwiretap.la \
- ../wsutil/libwsutil.la \
- @GLIB_LIBS@ \
- @LIBSSH_LIBS@
-
-ciscodump_SOURCES = \
- ciscodump.c \
- extcap-base.c \
- ssh-base.c
-
-# Libraries and plugin flags with which to link ciscodump.
-ciscodump_LDADD = \
- ../writecap/libwritecap.a \
- ../wsutil/libwsutil.la \
- @GLIB_LIBS@ \
- @LIBSSH_LIBS@
-
-udpdump_SOURCES = \
- udpdump.c \
- extcap-base.c
-
-# Libraries and plugin flags with which to link udpdump.
-udpdump_LDADD = \
- ../writecap/libwritecap.a \
- ../wsutil/libwsutil.la \
- @GLIB_LIBS@
-
-noinst_HEADERS = \
- extcap-base.h \
- ssh-base.h