aboutsummaryrefslogtreecommitdiffstats
path: root/epan/wmem/Makefile.am
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2017-09-03 00:42:00 +0100
committerJoão Valverde <j@v6e.pt>2017-09-15 10:11:55 +0000
commite7ef19efc0e928b50644b37772ccbf176e74f766 (patch)
tree1d6a4bb5163e5b094d5c5879d96b961113258315 /epan/wmem/Makefile.am
parentc52a702ae81b1ae7311a8b58e625f86fb211e7c5 (diff)
autotools: Initial work to install headers for the benefit of plugins
Install public headers required to build plugins for libwireshark (taps and dissectors). The source tree is organized to serve the CLI/GUI parts of wireshark. Plugins are built in tree. This change is intende to allow plugins to be built out-of-tree but we want to avoid dumping all headers into /usr/include. To be continued incrementally to fix errors and omissions. Change-Id: Iaa0def0ba3de4b456a29114c315544d2d64fa748 Reviewed-on: https://code.wireshark.org/review/23374 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'epan/wmem/Makefile.am')
-rw-r--r--epan/wmem/Makefile.am32
1 files changed, 18 insertions, 14 deletions
diff --git a/epan/wmem/Makefile.am b/epan/wmem/Makefile.am
index e2e316ca6a..dd2962ac01 100644
--- a/epan/wmem/Makefile.am
+++ b/epan/wmem/Makefile.am
@@ -28,6 +28,24 @@ noinst_LTLIBRARIES = libwmem.la
EXTRA_PROGRAMS = wmem_test
+subpkgincludedir = $(pkgincludedir)/epan/wmem
+
+subpkginclude_HEADERS = \
+ wmem.h \
+ wmem_array.h \
+ wmem_core.h \
+ wmem_list.h \
+ wmem_map.h \
+ wmem_miscutl.h \
+ wmem_queue.h \
+ wmem_scopes.h \
+ wmem_stack.h \
+ wmem_strbuf.h \
+ wmem_strutl.h \
+ wmem_tree.h \
+ wmem_interval_tree.h \
+ wmem_user_cb.h
+
libwmem_la_SOURCES = \
wmem_array.c \
wmem_core.c \
@@ -45,27 +63,13 @@ libwmem_la_SOURCES = \
wmem_tree.c \
wmem_interval_tree.c \
wmem_user_cb.c \
- wmem.h \
- wmem_array.h \
- wmem_core.h \
wmem_allocator.h \
wmem_allocator_block.h \
wmem_allocator_block_fast.h \
wmem_allocator_simple.h \
wmem_allocator_strict.h \
- wmem_list.h \
- wmem_map.h \
wmem_map_int.h \
- wmem_miscutl.h \
- wmem_queue.h \
- wmem_scopes.h \
- wmem_stack.h \
- wmem_strbuf.h \
- wmem_strutl.h \
- wmem_tree.h \
wmem_tree-int.h \
- wmem_interval_tree.h \
- wmem_user_cb.h \
wmem_user_cb_int.h
wmem_test_SOURCES = wmem_test.c