aboutsummaryrefslogtreecommitdiffstats
path: root/epan/dissectors/dcerpc/Makefile.am
diff options
context:
space:
mode:
authorDario Lombardo <lomato@gmail.com>2015-08-14 12:02:38 +0200
committerMichael Mann <mmann78@netscape.net>2015-09-02 02:28:23 +0000
commit87f2bd45fc5f7ec2ee7b241df54ecca110280cec (patch)
tree51cef60a22795118c86e4061849859f738394161 /epan/dissectors/dcerpc/Makefile.am
parentaa1f55610b4a872eb1160a27fae1fa12cd28a5ed (diff)
idl2wrs: some code cleanups.
Code cleanups include: - sanity checks for malloc() - change forbidden APIs into g_* versions - minor indentation fixes - add modeline - add compilation for cmake and autotools Bug: 11052 Change-Id: I825f04d9703448f9165d188be2bdd185fce5ff5d Reviewed-on: https://code.wireshark.org/review/10030 Petri-Dish: Alexis La Goutte <alexis.lagoutte@gmail.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Alexis La Goutte <alexis.lagoutte@gmail.com> Reviewed-by: Michael Mann <mmann78@netscape.net>
Diffstat (limited to 'epan/dissectors/dcerpc/Makefile.am')
-rw-r--r--epan/dissectors/dcerpc/Makefile.am23
1 files changed, 20 insertions, 3 deletions
diff --git a/epan/dissectors/dcerpc/Makefile.am b/epan/dissectors/dcerpc/Makefile.am
index 44cd795b62..33ffe04dc1 100644
--- a/epan/dissectors/dcerpc/Makefile.am
+++ b/epan/dissectors/dcerpc/Makefile.am
@@ -19,8 +19,6 @@
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
-# Don't build anything, just add this stuff to the source tarball
-
EXTRA_DIST = \
CMakeLists.txt \
Makefile.inc \
@@ -42,4 +40,23 @@ EXTRA_DIST = \
drsuapi/packet-dcerpc-drsuapi-template.h
MAINTAINERCLEANFILES = \
- Makefile.in
+ Makefile.in
+
+bin_PROGRAMS = idl2wrs
+
+idl2wrs_SOURCES = idl2wrs.c
+
+idl2wrs_LDADD = @GLIB_LIBS@
+
+#
+# Editor modelines - https://www.wireshark.org/tools/modelines.html
+#
+# Local variables:
+# c-basic-offset: 4
+# tab-width: 4
+# indent-tabs-mode: t
+# End:
+#
+# vi: set shiftwidth=4 tabstop=4 noexpandtab:
+# :indentSize=4:tabSize=4:noTabs=false:
+#