aboutsummaryrefslogtreecommitdiffstats
path: root/epan/dissectors/CMakeLists.txt
diff options
context:
space:
mode:
authorGraham Bloice <graham.bloice@trihedral.com>2021-04-10 19:15:34 +0100
committerGraham Bloice <graham.bloice@trihedral.com>2021-05-14 12:11:03 +0100
commitf6ad4812a2d8ee56b90fb204f00d54af27855992 (patch)
tree0173a6d55d84d6e2f0f18b027d7da8c235150c6c /epan/dissectors/CMakeLists.txt
parent2c62e2eb3ff1c700ccd79e6853f50aeac9832d8c (diff)
Add SparkplugB dissector
Add a dissector for SparkplugB as a heuristic subdissector of MQTT and which calls protobuf to dissect the messages payload.
Diffstat (limited to 'epan/dissectors/CMakeLists.txt')
-rw-r--r--epan/dissectors/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/epan/dissectors/CMakeLists.txt b/epan/dissectors/CMakeLists.txt
index 48e607c198..d430db1959 100644
--- a/epan/dissectors/CMakeLists.txt
+++ b/epan/dissectors/CMakeLists.txt
@@ -1773,6 +1773,7 @@ set(DISSECTOR_SRC
${CMAKE_CURRENT_SOURCE_DIR}/packet-someip.c
${CMAKE_CURRENT_SOURCE_DIR}/packet-someip-sd.c
${CMAKE_CURRENT_SOURCE_DIR}/packet-soupbintcp.c
+ ${CMAKE_CURRENT_SOURCE_DIR}/packet-sparkplug.c
${CMAKE_CURRENT_SOURCE_DIR}/packet-spdy.c
${CMAKE_CURRENT_SOURCE_DIR}/packet-spice.c
${CMAKE_CURRENT_SOURCE_DIR}/packet-spp.c