aboutsummaryrefslogtreecommitdiffstats
path: root/epan/dissectors/CMakeLists.txt
diff options
context:
space:
mode:
authorMaxim Kropp <maxim.kropp@hotmail.de>2020-09-15 19:12:31 +0200
committerMartin Mathieson <martin.r.mathieson@googlemail.com>2020-09-17 19:55:52 +0000
commite5921672f8e81560305fc00333df4e59b3f482a0 (patch)
tree525370df9818ad3a827b03776ac2aee071ad0797 /epan/dissectors/CMakeLists.txt
parent34f60a1cfcfaf75ecf8308bf05ad7837e0148c12 (diff)
New dissector: ILDA Digital Network (IDN) Protocol
Stream Specification: https://www.ilda.com/resources/StandardsDocs/ILDA_IDN-Stream_rev001.pdf The stream specification only defines IDN messages. The other packet commands like ping request, ping response, etc. (see line 25 - 31 in packet-idn.c) are part of the hello specification which is not released yet. We were still able to implement some hello packets since we received a preliminary version of the hello specification, because we need the hello packets for our work. related to #16707
Diffstat (limited to 'epan/dissectors/CMakeLists.txt')
-rw-r--r--epan/dissectors/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/epan/dissectors/CMakeLists.txt b/epan/dissectors/CMakeLists.txt
index 899fba8a15..5f0e20cbdf 100644
--- a/epan/dissectors/CMakeLists.txt
+++ b/epan/dissectors/CMakeLists.txt
@@ -117,6 +117,7 @@ set(CLEAN_ASN1_DISSECTOR_SRC
${CMAKE_CURRENT_SOURCE_DIR}/packet-h501.c
${CMAKE_CURRENT_SOURCE_DIR}/packet-hnbap.c
${CMAKE_CURRENT_SOURCE_DIR}/packet-idmp.c
+ ${CMAKE_CURRENT_SOURCE_DIR}/packet-idn.c
${CMAKE_CURRENT_SOURCE_DIR}/packet-ilp.c
${CMAKE_CURRENT_SOURCE_DIR}/packet-inap.c
${CMAKE_CURRENT_SOURCE_DIR}/packet-isdn-sup.c