aboutsummaryrefslogtreecommitdiffstats
path: root/epan/dissectors/CMakeLists.txt
diff options
context:
space:
mode:
authorDr. Lars Völker <lars.voelker@technica-engineering.de>2021-01-15 20:28:08 +0100
committerAndersBroman <a.broman58@gmail.com>2021-01-16 07:26:08 +0000
commit8203e104888085086c5eaea68cf2bada71f09edc (patch)
treecaf8b61402323772ff5f5837a90019537fb52fa5 /epan/dissectors/CMakeLists.txt
parent737e18d37b5c9170b709d79aa661b18080df61c8 (diff)
SOME/IP: Fix subdissector support
Until now writing subdissectors for SOME/IP was not really possible. While you could register for messages, the subdissector did not know which message it was called for. This patch fixes the subdissector support of SOME/IP by: - adding header file to CMakeLists (was missing) - creating a "data" struct so that subdissectors know what they dissect - passing this "data" struct to the subdissector
Diffstat (limited to 'epan/dissectors/CMakeLists.txt')
-rw-r--r--epan/dissectors/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/epan/dissectors/CMakeLists.txt b/epan/dissectors/CMakeLists.txt
index 6e8a5b41be..01b05fb254 100644
--- a/epan/dissectors/CMakeLists.txt
+++ b/epan/dissectors/CMakeLists.txt
@@ -563,6 +563,7 @@ set(DISSECTOR_PUBLIC_HEADERS
packet-smrse.h
packet-snmp.h
packet-socketcan.h
+ packet-someip.h
packet-spice.h
packet-sprt.h
packet-sscop.h