aboutsummaryrefslogtreecommitdiffstats
path: root/epan/configure.in
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2003-05-04 18:50:56 +0000
committerGerald Combs <gerald@wireshark.org>2003-05-04 18:50:56 +0000
commit1d9b54fc072952758813d6cbce25bbe1ef8c2ac3 (patch)
tree1fc6bf8e2065199f49398fdfb4c3ef23ac1ab398 /epan/configure.in
parent5cc92eeb86806e56d7524c4887716b688fbdd0ca (diff)
Add support for asynchronous DNS updates using the GNU ADNS library.
Support can be enabled at configure time by using "--with-adns=DIR". If support is enabled, async queries happen whenever host name resolution is enabled. Do we need a separate preference for async queries? Currently, only IPv4 reverse queries are supported. I can add IPv4 forward lookup support, but I don't have any way to test IPv6 queries. svn path=/trunk/; revision=7640
Diffstat (limited to 'epan/configure.in')
-rw-r--r--epan/configure.in11
1 files changed, 10 insertions, 1 deletions
diff --git a/epan/configure.in b/epan/configure.in
index 94074a08cc..ad4f15dd78 100644
--- a/epan/configure.in
+++ b/epan/configure.in
@@ -1,4 +1,4 @@
-# $Id: configure.in,v 1.42 2003/05/01 03:09:54 gerald Exp $
+# $Id: configure.in,v 1.43 2003/05/04 18:50:53 gerald Exp $
dnl
dnl Process this file with autoconf 2.13 or later to produce a
dnl configure script; 2.12 doesn't generate a "configure" script that
@@ -219,6 +219,15 @@ AC_CHECK_FUNC(strptime, ,
[AC_DEFINE(NEED_STRPTIME_H, 1, [Define if strptime.h needs to be included])
])
+dnl ADNS Check
+AC_MSG_CHECKING(whether to use the GNU ADNS library if available)
+if test "x$enable_adns" = "xno" ; then
+ AC_MSG_RESULT(no)
+else
+ AC_MSG_RESULT(yes)
+ AC_ETHEREAL_ADNS_CHECK
+fi
+
#
# Check whether GLib modules are supported, to determine whether we
# can support plugins.