aboutsummaryrefslogtreecommitdiffstats
path: root/epan/Makefile.am
diff options
context:
space:
mode:
authorJeff Morriss <jeff.morriss@ulticom.com>2008-09-16 19:24:25 +0000
committerJeff Morriss <jeff.morriss@ulticom.com>2008-09-16 19:24:25 +0000
commit98fd7b71dfc0b8e34862c57b77c30168907520d4 (patch)
tree517ab2aaea19520c8b94a121617ceff2d3fab799 /epan/Makefile.am
parentd934f6786d943f2abe1b286d3c7fa3b70f6fd94f (diff)
Link libwireshark and wiretap against libwsutil. That was the original intent
of adding libwsutil but somehow I missed it/got it wrong. This should solve https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=1677#c18 Also remove the _DEPENDENCIES lines in epan and wiretap (as was done in the top-level Makefile in rev 25930) so that automake will automatically figure out the dependencies for us. Since the those 2 libraries now link against libwsutil, don't make every executable link against the library. (If this works I think we can significantly trim the list of libraries the executables link against and just let the libraries pull in what they need--which is, apparently, the point of the --as-needed flag: http://www.gentoo.org/proj/en/qa/asneeded.xml ). svn path=/trunk/; revision=26218
Diffstat (limited to 'epan/Makefile.am')
-rw-r--r--epan/Makefile.am10
1 files changed, 3 insertions, 7 deletions
diff --git a/epan/Makefile.am b/epan/Makefile.am
index e8cf6f0cab..2564f1faf8 100644
--- a/epan/Makefile.am
+++ b/epan/Makefile.am
@@ -127,13 +127,9 @@ libwireshark_la_LIBADD = \
libwireshark_asmopt.la crypt/libairpdcap.la ftypes/libftypes.la \
dfilter/libdfilter.la dissectors/libdissectors.la \
dissectors/libdirtydissectors.la $(wslua_lib) @SOCKET_LIBS@ @NSL_LIBS@ \
- @C_ARES_LIBS@ @ADNS_LIBS@ @LIBGCRYPT_LIBS@ @LIBGNUTLS_LIBS@ @KRB5_LIBS@ \
- @SSL_LIBS@ @LIBSMI_LDFLAGS@ -lm
-libwireshark_la_DEPENDENCIES = \
- @INET_ATON_LO@ @INET_PTON_LO@ @INET_NTOP_LO@ libwireshark_generated.la \
- libwireshark_asmopt.la crypt/libairpdcap.la ftypes/libftypes.la \
- dfilter/libdfilter.la dissectors/libdissectors.la \
- dissectors/libdirtydissectors.la $(wslua_lib)
+ @C_ARES_LIBS@ @ADNS_LIBS@ @LIBGCRYPT_LIBS@ @LIBGNUTLS_LIBS@ \
+ @KRB5_LIBS@ @SSL_LIBS@ @LIBSMI_LDFLAGS@ \
+ ${top_builddir}/wsutil/libwsutil.la -lm
#EXTRA_PROGRAMS = reassemble_test
#reassemble_test_LDADD = $(GLIB_LIBS)