aboutsummaryrefslogtreecommitdiffstats
path: root/epan/Makefile.am
diff options
context:
space:
mode:
authorSebastien Tandel <sebastien@tandel.be>2009-05-29 21:10:40 +0000
committerSebastien Tandel <sebastien@tandel.be>2009-05-29 21:10:40 +0000
commit52cc5fb1e86ac8007eabe1291bf543d3803f7148 (patch)
tree0ee2757e438e9d9db9dd0ddab19f0e84f3f29f03 /epan/Makefile.am
parentcb4f0a40c23a3247fbb74a74dc117cbef4f83bf4 (diff)
python binding for wireshark (first commit)
* ability to write dissectors with python for wireshark. documentation (http://wiki.wireshark.org/Python) svn path=/trunk/; revision=28529
Diffstat (limited to 'epan/Makefile.am')
-rw-r--r--epan/Makefile.am21
1 files changed, 16 insertions, 5 deletions
diff --git a/epan/Makefile.am b/epan/Makefile.am
index 8e93076d8f..aa1d448552 100644
--- a/epan/Makefile.am
+++ b/epan/Makefile.am
@@ -34,10 +34,21 @@ wslua_dir =
wslua_dist_dir = wslua
endif # HAVE_LIBLUA
+if HAVE_LIBPY
+wspython_lib = wspython/libwspython.la
+wspython_dir = wspython
+wspython_dist_dir =
+py_dissectors_dir = -DPYTHON_DIR=\"@pythondir@\"
+else
+wspython_lib =
+wspython_dir =
+wspython_dist_dir = wspython
+py_dissectors_dir = -DPYTHONDIR=
+endif
-SUBDIRS = crc crypt ftypes dfilter dissectors $(wslua_dir)
+SUBDIRS = crc crypt ftypes dfilter dissectors $(wslua_dir) $(wspython_dir)
-DIST_SUBDIRS = $(SUBDIRS) $(wslua_dist_dir)
+DIST_SUBDIRS = $(SUBDIRS) $(wslua_dist_dir) $(wspython_dist_dir)
ACLOCAL_AMFLAGS = `../aclocal-flags`
@@ -63,7 +74,7 @@ endif
libwireshark_la_SOURCES = \
$(LIBWIRESHARK_SRC) \
$(LIBWIRESHARK_INCLUDES)
-libwireshark_la_CFLAGS = $(AM_NON_GENERATED_CFLAGS)
+libwireshark_la_CFLAGS = $(AM_NON_GENERATED_CFLAGS) $(py_dissectors_dir)
libwireshark_generated_la_SOURCES = \
$(LIBWIRESHARK_GENERATED_SRC) \
@@ -127,7 +138,7 @@ libwireshark_la_LIBADD = \
@INET_ATON_LO@ @INET_PTON_LO@ @INET_NTOP_LO@ libwireshark_generated.la \
libwireshark_asmopt.la crc/libcrc.la crypt/libairpdcap.la \
ftypes/libftypes.la dfilter/libdfilter.la dissectors/libdissectors.la \
- dissectors/libdirtydissectors.la $(wslua_lib) @SOCKET_LIBS@ @NSL_LIBS@ \
+ dissectors/libdirtydissectors.la $(wslua_lib) $(wspython_lib) @SOCKET_LIBS@ @NSL_LIBS@ \
@C_ARES_LIBS@ @ADNS_LIBS@ @LIBGCRYPT_LIBS@ @LIBGNUTLS_LIBS@ \
@KRB5_LIBS@ @SSL_LIBS@ @LIBSMI_LDFLAGS@ @GEOIP_LIBS@ \
${top_builddir}/wsutil/libwsutil.la -lm
@@ -136,7 +147,7 @@ libwireshark_la_DEPENDENCIES = \
@INET_ATON_LO@ @INET_PTON_LO@ @INET_NTOP_LO@ libwireshark_generated.la \
libwireshark_asmopt.la crc/libcrc.la crypt/libairpdcap.la \
ftypes/libftypes.la dfilter/libdfilter.la dissectors/libdissectors.la \
- dissectors/libdirtydissectors.la $(wslua_lib) \
+ dissectors/libdirtydissectors.la $(wslua_lib) $(wspython_lib) \
${top_builddir}/wsutil/libwsutil.la
#EXTRA_PROGRAMS = reassemble_test