aboutsummaryrefslogtreecommitdiffstats
path: root/epan/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael Mann <mmann78@netscape.net>2019-01-01 12:17:55 -0500
committerMichael Mann <mmann78@netscape.net>2019-02-18 00:49:51 +0000
commite797e751746858eed7231767ac3e244e46ea5840 (patch)
tree16226f6bea46af20b532c1dda9ba08db7bb7521a /epan/CMakeLists.txt
parent9f75af5b2596c08fc32484d18d80c09245f177e8 (diff)
Include epan header files in VS solution.
Add header files lists to add_library() so that Visual Studio can pick them up and include them in a "Header Files" folder for easier navigation within Visual Studio. Change-Id: I7cd8e39550f4db67eed8205593060ae8b4a5b1b9 Reviewed-on: https://code.wireshark.org/review/31289 Petri-Dish: Michael Mann <mmann78@netscape.net> Tested-by: Petri Dish Buildbot Reviewed-by: Michael Mann <mmann78@netscape.net>
Diffstat (limited to 'epan/CMakeLists.txt')
-rw-r--r--epan/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/epan/CMakeLists.txt b/epan/CMakeLists.txt
index 651a8d2711..bd13510591 100644
--- a/epan/CMakeLists.txt
+++ b/epan/CMakeLists.txt
@@ -185,6 +185,10 @@ set(LIBWIRESHARK_PUBLIC_HEADERS
xdlc.h
)
+set(LIBWIRESHARK_HEADER_FILES
+ ${LIBWIRESHARK_PUBLIC_HEADERS}
+)
+
set(LIBWIRESHARK_NONGENERATED_FILES
addr_and_mask.c
addr_resolv.c
@@ -293,6 +297,9 @@ set_source_files_properties(
)
add_library(epan
+ #Included so that Visual Studio can properly put header files in solution
+ ${LIBWIRESHARK_HEADER_FILES}
+
${LIBWIRESHARK_FILES}
$<TARGET_OBJECTS:crypt>
$<TARGET_OBJECTS:dfilter>