aboutsummaryrefslogtreecommitdiffstats
path: root/epan/CMakeLists.txt
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2018-11-27 19:37:33 +0000
committerJoão Valverde <j@v6e.pt>2018-11-29 02:21:51 +0000
commit40352d75cd187201b46c13acc0e03c0d73785e51 (patch)
treeb1e3c57443c88fe782e562d8c0c066d4d9f6af63 /epan/CMakeLists.txt
parent332df929a9966fda2cd3aa30a5a107e5b2bfa360 (diff)
CMake: Fix some transitive link dependencies
libwireshark and libwiretap have their INTERFACE link dependencies changed to the required set. libwsutil keeps a default public visibility. Further work may show some unneeded link requirements. The executable dependencies are adjusted accordingly. Change-Id: I3a534f72403819cac136ae47a3d80acee76e0fb3 Reviewed-on: https://code.wireshark.org/review/30815 Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'epan/CMakeLists.txt')
-rw-r--r--epan/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/epan/CMakeLists.txt b/epan/CMakeLists.txt
index 9f03a1f8f2..ff9ca8f2d9 100644
--- a/epan/CMakeLists.txt
+++ b/epan/CMakeLists.txt
@@ -378,6 +378,7 @@ target_link_libraries(epan
${SNAPPY_LIBRARIES}
${WIN_PSAPI_LIBRARY}
${LIBXML2_LIBRARIES}
+ ${ZLIB_LIBRARIES}
)
target_include_directories(epan