aboutsummaryrefslogtreecommitdiffstats
path: root/docbook/Makefile.am
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2017-09-25 14:06:37 -0700
committerGerald Combs <gerald@wireshark.org>2017-09-25 23:05:11 +0000
commite2d43e7d4b352206bac6bdd42f2c8f04d1e126b2 (patch)
tree03d51a4ecfe9c4aa3cc1225ed93f2ae6c4200992 /docbook/Makefile.am
parentf3d9766cbc83316544aae7fdd0f0f854160eafa3 (diff)
Docbook: Automatically generate the tools help output.
Add a CMake target that dumps the help output for our command line tools to individual files. Include those files in the tools appendix instead of pasting them in manually. Fixup the output of some tools so that they pass the pre-commit checks. Change-Id: I925f24818422a190927a96531c21f4d16d3fe5b5 Reviewed-on: https://code.wireshark.org/review/23737 Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'docbook/Makefile.am')
-rw-r--r--docbook/Makefile.am15
1 files changed, 14 insertions, 1 deletions
diff --git a/docbook/Makefile.am b/docbook/Makefile.am
index 3434ff996b..e67bbe6e32 100644
--- a/docbook/Makefile.am
+++ b/docbook/Makefile.am
@@ -36,6 +36,18 @@ WSUG_FILES = \
wsug_src/WSUG_preface.asciidoc \
ws.css
+WSUG_TOOLS_HELP_FILES = \
+ wsug_src/capinfos-h.txt
+ wsug_src/dumpcap-h.txt
+ wsug_src/editcap-F.txt
+ wsug_src/editcap-T.txt
+ wsug_src/editcap-h.txt
+ wsug_src/mergecap-h.txt
+ wsug_src/rawshark-h.txt
+ wsug_src/reordercap-h.txt
+ wsug_src/text2pcap-h.txt
+ wsug_src/tshark-h.txt
+
WSUG_GENERATED_SOURCE = \
user-guide.xml
@@ -229,6 +241,7 @@ WSUG_DIST = \
custom_layer_chm.xsl \
custom_layer_pdf.xsl \
$(WSUG_FILES) \
+ $(WSUG_TOOLS_HELP_FILES) \
$(WSUG_GRAPHICS) \
$(COMMON_FILES) \
$(COMMON_GRAPHICS)
@@ -357,7 +370,7 @@ wsug: wsug_html_chunked wsug_html
wsug-pdf: wsug user-guide-a4.pdf user-guide-us.pdf
-user-guide.xml: user-guide.asciidoc $(WSUG_FILES)
+user-guide.xml: user-guide.asciidoc $(WSUG_FILES) $(WSUG_TOOLS_HELP_FILES)
$(A2X) --verbose \
--attribute=docinfo \
--asciidoc-opts="--conf-file=$(srcdir)/asciidoc.conf --conf-file=$(srcdir)/asciidoctor-asciidoc.conf" \