aboutsummaryrefslogtreecommitdiffstats
path: root/docbook/Makefile.am
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2017-10-14 20:11:24 +0100
committerMichael Mann <mmann78@netscape.net>2017-10-22 13:10:50 +0000
commitaa04d2355effb1cf611831b0a260cf1aff199b9a (patch)
treef9283f8970773a6243ceb9d534b1c31d8be7bc08 /docbook/Makefile.am
parentb0432442c607c7d71e40c55ffd0bf46f43ef3d1a (diff)
autotools: Build and install user guide
Installs the WSUG to $docdir, unless the --disable-guides option is given to the configure script. This will open the Help->Contents menu action using the locally installed guide. It will also point to the correct version for this Wireshark release. The wireshark.org link only provides the guide for the master branch. Change-Id: I9dd539c737cb3777dc1351707b9e45a3a6764aaa Reviewed-on: https://code.wireshark.org/review/23906 Petri-Dish: João Valverde <j@v6e.pt> Reviewed-by: João Valverde <j@v6e.pt> Tested-by: João Valverde <j@v6e.pt> Reviewed-by: Michael Mann <mmann78@netscape.net>
Diffstat (limited to 'docbook/Makefile.am')
-rw-r--r--docbook/Makefile.am18
1 files changed, 17 insertions, 1 deletions
diff --git a/docbook/Makefile.am b/docbook/Makefile.am
index 0634b41810..4a3d7a4b54 100644
--- a/docbook/Makefile.am
+++ b/docbook/Makefile.am
@@ -361,7 +361,14 @@ HTMLHELP_XSLTPROC_ARGS = \
.fo.pdf:
FOP_OPTS=$(FOP_OPTS) JAVA_OPTS=$(FOP_OPTS) $(FOP) $< $@
-all: wsug wsdg release-notes
+docbook_all_local_targets =
+if BUILD_USER_GUIDE
+docbook_all_local_targets += wsug_html_chunked
+endif
+
+all-local: $(docbook_all_local_targets)
+
+all-html: wsug wsdg release-notes
all-pdf: wsug-pdf wsdg-pdf release-notes-pdf
@@ -541,6 +548,15 @@ release-notes-a4.pdf: $(RELEASE_NOTES_SOURCE) custom_layer_pdf.xsl
--destination-dir=$(builddir) \
$(srcdir)/release-notes.asciidoc
+install-data-local:
+if BUILD_USER_GUIDE
+ $(MKDIR_P) $(DESTDIR)$(docdir)/guides
+ cp -rf $(builddir)/wsug_html_chunked $(DESTDIR)$(docdir)/guides
+endif
+
+uninstall-local:
+ rm -rf $(DESTDIR)$(docdir)
+
clean-local:
-rm -rf $(CLEANDIRS)