aboutsummaryrefslogtreecommitdiffstats
path: root/docbook/Makefile.am
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2018-01-23 11:02:16 -0800
committerGerald Combs <gerald@wireshark.org>2018-01-23 22:15:01 +0000
commit787b93fd071e1537b33e8d2f894bbc3cc0ed5595 (patch)
tree8fac31366ccc4a0789e85d5e695fa63e7169d795 /docbook/Makefile.am
parent6605d844afa3d804da89970ee46845cfa986994b (diff)
Docbook: Generate one PDF paper size.
Generate a single PA4-sized PDF. PA4 is the approximate intersection of A4 and Letter[1]. This gives us one less file to build and distribute. If you're printing out hard copies of the guides this wastes a few pages compared to an A4-sized PDF, but if you're printing out hard copies of the guides you've already made a strong commitment to waste paper. Page counts: Guide Size Pages WSDG A4 203 WSDG Letter 217 WSDG PA4 217 WSUG A4 192 WSUG Letter 204 WSUG PA4 205 [1] https://en.wikipedia.org/wiki/Paper_size#PA4_or_L4 Change-Id: If43d4b19947c77a51b3943a2b329dbab45025d79 Reviewed-on: https://code.wireshark.org/review/25438 Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'docbook/Makefile.am')
-rw-r--r--docbook/Makefile.am63
1 files changed, 12 insertions, 51 deletions
diff --git a/docbook/Makefile.am b/docbook/Makefile.am
index c4af2096d4..08093f977e 100644
--- a/docbook/Makefile.am
+++ b/docbook/Makefile.am
@@ -370,12 +370,12 @@ all-local: $(docbook_all_local_targets)
all-html: wsug wsdg release-notes
-all-pdf: wsug-pdf wsdg-pdf release-notes-pdf
+all-pdf: wsug-pdf wsdg-pdf
# Wireshark User Guide
wsug: wsug_html_chunked wsug_html
-wsug-pdf: wsug user-guide-a4.pdf user-guide-us.pdf
+wsug-pdf: wsug user-guide.pdf
user-guide.xml: user-guide.asciidoc $(WSUG_FILES) $(WSUG_TOOLS_HELP_FILES)
$(A2X) --verbose \
@@ -414,19 +414,11 @@ wsug_html_chunked/index.html: $(WSUG_SOURCE)
$(WSUG_XSLTPROC_ARGS) $(CHUNKED_XSLTPROC_ARGS) $<
-chmod -R og+rX wsug_html_chunked
-# create pdf file (through XSL-FO), portrait pages on US letter paper
-# you will get lot's of errors, but that's ok
-user-guide-us.fo: $(WSUG_SOURCE) custom_layer_pdf.xsl
- @ echo --- WSUG - PDF US PAPER ---
- $(XSLTPROC) --stringparam paper.type letter \
- $(COMMON_XSLTPROC_ARGS) $(WSUG_PDF_XSLTPROC_ARGS) \
- --nonet $(srcdir)/custom_layer_pdf.xsl $< > $@
-
-# create pdf file (through XSL-FO), portrait pages on A4 paper
-# you will get lot's of errors, but that's ok
-user-guide-a4.fo: $(WSUG_SOURCE) custom_layer_pdf.xsl
- @ echo --- WSUG - PDF A4 PAPER ---
- $(XSLTPROC) --stringparam paper.type A4 \
+# create pdf file (through XSL-FO), portrait pages on PA4 (210 x 280 mm) "paper"
+# you will get lots of errors, but that's ok
+user-guide.fo: $(WSUG_SOURCE) custom_layer_pdf.xsl
+ @ echo --- WSUG - PDF PA4 PAPER ---
+ $(XSLTPROC) \
$(COMMON_XSLTPROC_ARGS) $(WSUG_PDF_XSLTPROC_ARGS) \
--nonet $(srcdir)/custom_layer_pdf.xsl $< > $@
@@ -439,7 +431,7 @@ wsluarm: make-wsluarm.pl $(WSLUA_MODULES)
# Wireshark Developer Guide
wsdg: wsdg_html_chunked wsdg_html
-wsdg-pdf: wsdg developer-guide-a4.pdf developer-guide-us.pdf
+wsdg-pdf: wsdg developer-guide.pdf
developer-guide.xml: developer-guide.asciidoc $(WSDG_FILES) wsluarm
$(A2X) --verbose \
@@ -481,20 +473,11 @@ wsdg_html_chunked/index.html: $(WSDG_SOURCE)
$(WSDG_XSLTPROC_ARGS) $(CHUNKED_XSLTPROC_ARGS) $<
-chmod -R og+rX wsdg_html_chunked
-# create pdf file (through XSL-FO), portrait pages on US letter paper
+# create pdf file (through XSL-FO), portrait pages on PA4 (210 x 280 mm) "paper"
# you will get lot's of errors, but that's ok
-developer-guide-us.fo: $(WSDG_SOURCE) custom_layer_pdf.xsl
- @ echo --- WSDG - PDF US PAPER ---
- $(XSLTPROC) --stringparam paper.type letter \
- $(COMMON_XSLTPROC_ARGS) $(WSDG_PDF_XSLTPROC_ARGS) \
- --path .:wsluarm_src:$(srcdir) \
- --nonet $(srcdir)/custom_layer_pdf.xsl $< > $@
-
-# create pdf file (through XSL-FO), portrait pages on A4 paper
-# you will get lot's of errors, but that's ok
-developer-guide-a4.fo: $(WSDG_SOURCE) custom_layer_pdf.xsl
- @ echo --- WSDG - PDF A4 PAPER ---
- $(XSLTPROC) --stringparam paper.type A4 \
+developer-guide.fo: $(WSDG_SOURCE) custom_layer_pdf.xsl
+ @ echo --- WSDG - PDF PA4 PAPER ---
+ $(XSLTPROC) \
$(COMMON_XSLTPROC_ARGS) $(WSDG_PDF_XSLTPROC_ARGS) \
--path .:wsluarm_src:$(srcdir) \
--nonet $(srcdir)/custom_layer_pdf.xsl $< > $@
@@ -506,8 +489,6 @@ else
release-notes: release-notes.html
endif
-release-notes-pdf: release-notes release-notes-a4.pdf release-notes-us.pdf
-
# create html single page file
release-notes.html: $(RELEASE_NOTES_SOURCE)
@ echo --- RELEASE NOTES - HTML ---
@@ -528,26 +509,6 @@ news: release-notes.txt
cp release-notes.txt ../NEWS
-cp release-notes.txt $(top_srcdir)/NEWS
-# Apparently we can only run one instance of a2x at a time.
-.NOTPARALLEL: release-notes-us.pdf release-notes-a4.pdf
-# create pdf file, portrait pages on US letter paper
-release-notes-us.pdf: $(RELEASE_NOTES_SOURCE) custom_layer_pdf.xsl
- @ echo --- RELEASE NOTES - PDF US LETTER PAPER ---
- $(A2X) --format=pdf $(A2X_HTML_OPTS) --fop \
- --xsltproc-opts "--stringparam paper.type letter --nonet" \
- --xsl-file=$(srcdir)/custom_layer_pdf.xsl \
- --destination-dir=$(builddir) \
- $(srcdir)/release-notes.asciidoc
-
-# create pdf file, portrait pages on A4 paper
-release-notes-a4.pdf: $(RELEASE_NOTES_SOURCE) custom_layer_pdf.xsl
- @ echo --- RELEASE NOTES - PDF A4 PAPER ---
- $(A2X) --format=pdf $(A2X_HTML_OPTS) --fop \
- --xsltproc-opts "--stringparam paper.type A4 --nonet" \
- --xsl-file=$(srcdir)/custom_layer_pdf.xsl \
- --destination-dir=$(builddir) \
- $(srcdir)/release-notes.asciidoc
-
install-data-local:
if BUILD_USER_GUIDE
$(MKDIR_P) $(DESTDIR)$(docdir)/guides