aboutsummaryrefslogtreecommitdiffstats
path: root/doc/plugins.example/configure.ac
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2017-09-23 22:50:28 +0100
committerJoão Valverde <j@v6e.pt>2017-09-25 14:55:09 +0000
commitf64906413067f59b7bce5d149fd86b22ec392952 (patch)
tree7250b1b40ec4b87205c0804b7ac4096f9e9087a7 /doc/plugins.example/configure.ac
parent625bab309d9dd21db2d8ae2aa3511810d32842a8 (diff)
Add toy plugin to doc/ as an out-of-tree build example
Change-Id: I9b7abb27d30dbe83996a01b7f722693a974948c5 Reviewed-on: https://code.wireshark.org/review/23665 Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'doc/plugins.example/configure.ac')
-rw-r--r--doc/plugins.example/configure.ac29
1 files changed, 29 insertions, 0 deletions
diff --git a/doc/plugins.example/configure.ac b/doc/plugins.example/configure.ac
new file mode 100644
index 0000000000..07e9845d10
--- /dev/null
+++ b/doc/plugins.example/configure.ac
@@ -0,0 +1,29 @@
+dnl Process this file with autoconf to produce a configure script.
+dnl
+dnl This file is free software; as a special exception the author gives
+dnl unlimited permission to copy and/or distribute it, with or without
+dnl modifications, as long as this notice is preserved.
+dnl
+dnl This program is distributed in the hope that it will be useful, but
+dnl WITHOUT ANY WARRANTY, to the extent permitted by law; without even the
+dnl implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
+
+AC_INIT([Wireshark Hello Plugin], [0.0.1])
+
+AM_INIT_AUTOMAKE([foreign])
+
+AC_PREREQ([2.62])
+
+LT_PREREQ([2.2.2])
+LT_INIT([disable-static dlopen])
+
+AC_CONFIG_SRCDIR([hello.c])
+
+dnl Requires Wireshark 2.5.0 or greater.
+PKG_CHECK_MODULES([WIRESHARK], [wireshark >= 2.5])
+
+AC_CONFIG_HEADER([config.h])
+
+AC_CONFIG_FILES([Makefile])
+
+AC_OUTPUT