aboutsummaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorPeter Wu <peter@lekensteyn.nl>2019-07-27 14:39:38 +0100
committerPeter Wu <peter@lekensteyn.nl>2019-07-28 16:21:56 +0000
commitcfab27d464495389f7a20c691e5e5b2608b48abf (patch)
tree5f555a86a60a883de7879ba851b8501ee51d451c /debian
parentede4ecb8c8caff5ae45df51e93ff765ed15126ef (diff)
debian/rules: reduce log spam from asn1 target
There are 3694 warnings for one of the following two messages: UserWarning: The same field names for different types. Explicit field renaming is recommended. UserWarning: The same type names for different types. Explicit type renaming is recommended. Both warnings are accompanied by some context. Since the packager is unlikely going to address these issues, and CI systems struggle with the size of the generated logs, disable this subset of warnings. The output of `ninja asn1` shrinks from 28191 lines (2.4MiB) to 483 lines (32KiB). Change-Id: I44e9e1ab40f2255136fb1440e3bde2ccc9e55295 Reviewed-on: https://code.wireshark.org/review/34098 Petri-Dish: Peter Wu <peter@lekensteyn.nl> Tested-by: Petri Dish Buildbot Reviewed-by: Balint Reczey <balint@balintreczey.hu>
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules2
1 files changed, 2 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 7b3f0f87c9..bd036315af 100755
--- a/debian/rules
+++ b/debian/rules
@@ -27,6 +27,8 @@ override_dh_auto_configure:
dh_auto_configure -- -DBUILD_xxx2deb=ON
override_dh_auto_build:
+ # Ignore warnings from asn2wrs.py about duplicate field names.
+ PYTHONWARNINGS='ignore:The same:UserWarning::0' \
$(MAKE) -C $(CURDIR)/obj-* asn1
dh_auto_build
$(MAKE) -C $(CURDIR)/obj-* user_guide_html developer_guide_html