aboutsummaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorPeter Wu <peter@lekensteyn.nl>2019-06-23 05:26:12 +0100
committerPeter Wu <peter@lekensteyn.nl>2019-06-23 18:46:22 +0000
commitba3f25b3eec9d472e022629591b4653af1c8a07a (patch)
tree1067e1738dde5a70dfe1e39400fcf1fd8405724e /debian
parent7dfcb4425adf29590f3daf507d667b330a97b669 (diff)
debian/rules: remove unused variables
Neither VERSION nor docdir are used in CMake, remove it. The wheezy workaround was needed to fix build failures with PIE, but since Wheezy is EOL, it can be removed. 'distrelease' can also be removed, but let's keep it in case distro-specific workarounds are needed in the future. Change-Id: I6e8a296112b218ebce79f697bbb1def7c0efdad7 Reviewed-on: https://code.wireshark.org/review/33712 Petri-Dish: Alexis La Goutte <alexis.lagoutte@gmail.com> Tested-by: Petri Dish Buildbot Reviewed-by: Peter Wu <peter@lekensteyn.nl>
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules5
1 files changed, 0 insertions, 5 deletions
diff --git a/debian/rules b/debian/rules
index 300053705d..f4cc698916 100755
--- a/debian/rules
+++ b/debian/rules
@@ -19,12 +19,7 @@ endif
export DH_OPTIONS
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
-ifneq (,$(filter $(distrelease),wheezy))
-export DEB_LDFLAGS_MAINT_APPEND = -Wl,-Bsymbolic
-endif
-VERSION := $(shell dpkg-parsechangelog | sed -n 's/^Version: \(.*\)-.*/\1/p')
-export docdir = /usr/share/doc/wireshark-doc
%:
dh $@ --with python3 --buildsystem cmake --with quilt --parallel