aboutsummaryrefslogtreecommitdiffstats
path: root/debian/patches/03_preferences.dpatch
diff options
context:
space:
mode:
authorjake <jake@f5534014-38df-0310-8fa8-9805f1628bb7>2008-05-31 16:44:02 +0000
committerjake <jake@f5534014-38df-0310-8fa8-9805f1628bb7>2008-05-31 16:44:02 +0000
commitfce886a8b3ee118e2a1122a4cad90885c69423ec (patch)
treeca7b9be16043104bf492eddd25561e444597784b /debian/patches/03_preferences.dpatch
parent1a3f3fbf65ace582aab017ff72563d9262a57eb2 (diff)
Update Debian packaging files for Wireshark 1.0.
These files build the package with all features and minimum changes from the released sources. git-svn-id: http://anonsvn.wireshark.org/wireshark/trunk@25406 f5534014-38df-0310-8fa8-9805f1628bb7
Diffstat (limited to 'debian/patches/03_preferences.dpatch')
-rw-r--r--debian/patches/03_preferences.dpatch33
1 files changed, 13 insertions, 20 deletions
diff --git a/debian/patches/03_preferences.dpatch b/debian/patches/03_preferences.dpatch
index 43efafc5a9..6cc0183ff6 100644
--- a/debian/patches/03_preferences.dpatch
+++ b/debian/patches/03_preferences.dpatch
@@ -1,26 +1,19 @@
#! /bin/sh /usr/share/dpatch/dpatch-run
-## 03_preferences.dpatch by <fred@candle>
+## 03_preferences.dpatch by <fpeters@debian.org>
##
## All lines beginning with `## DP:' are a description of the patch.
## DP: use Debian sensible-browser
@DPATCH@
-diff -urNad wireshark-0.10.13~/configure.in wireshark-0.10.13/configure.in
---- wireshark-0.10.13~/configure.in 2005-12-08 12:47:00.000000000 +0100
-+++ wireshark-0.10.13/configure.in 2005-12-08 12:53:33.000000000 +0100
-@@ -38,12 +38,12 @@
- #
- AC_MSG_ERROR(I couldn't find pod2html; make sure it's installed and in your path)
- fi
--AC_PATH_PROG(HTML_VIEWER, htmlview)
-+AC_PATH_PROG(HTML_VIEWER, sensible-browser)
- if test "x$HTML_VIEWER" = x
- then
-- AC_DEFINE_UNQUOTED(HTML_VIEWER, "mozilla", [HTML viewer, e.g. mozilla])
-+ AC_DEFINE_UNQUOTED(HTML_VIEWER, "sensible-browser", [HTML viewer, e.g. sensible-browser])
- else
-- AC_DEFINE_UNQUOTED(HTML_VIEWER, "htmlview", [HTML viewer, e.g. mozilla])
-+ AC_DEFINE_UNQUOTED(HTML_VIEWER, "sensible-browser", [HTML viewer, e.g. mozilla])
- fi
-
- AC_PATH_PROG(LEX, flex)
+diff -urNad wireshark-0.99.7~pre1~/epan/prefs.c wireshark-0.99.7~pre1/epan/prefs.c
+--- wireshark-0.99.7~pre1~/epan/prefs.c 2007-11-22 17:57:25.000000000 +0100
++++ wireshark-0.99.7~pre1/epan/prefs.c 2007-11-22 18:04:50.555226510 +0100
+@@ -1198,7 +1198,7 @@
+ prefs.gui_ask_unsaved = TRUE;
+ prefs.gui_find_wrap = TRUE;
+ prefs.gui_use_pref_save = FALSE;
+- prefs.gui_webbrowser = g_strdup(HTML_VIEWER " %s");
++ prefs.gui_webbrowser = g_strdup("sensible-browser %s");
+ prefs.gui_window_title = g_strdup("");
+ prefs.gui_layout_type = layout_type_5;
+ prefs.gui_layout_content_1 = layout_pane_content_plist;