aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2008-10-24 18:08:32 +0000
committerGerald Combs <gerald@wireshark.org>2008-10-24 18:08:32 +0000
commite8aee91bc3119ec5e6bd0dc40117b5dae4a9682f (patch)
tree0c8058e5993129356b55d26375fec786ab9478b1 /configure.in
parent91eca9661ee634348304bde88d08da065cf65d59 (diff)
Add an option to look for the presence of Imendio's Mac OS X integration
functions in GTK+. svn path=/trunk/; revision=26539
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in24
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index a3a227e325..33f77298e2 100644
--- a/configure.in
+++ b/configure.in
@@ -675,6 +675,30 @@ else
have_plugins=no
fi
+dnl IGE Mac integration check
+AC_MSG_CHECKING(whether to use IGE Mac integration functions)
+
+AC_ARG_WITH(ige-mac-integration,
+ AC_HELP_STRING( [--with-ige-mac-integration],
+ [use IGE Mac integration. (@<:@default=yes, if supported in GTK+@:>@]),
+[
+ if test $withval = no
+ then
+ want_ige_mac_integration=no
+ else
+ want_ige_mac_integration=yes
+ fi
+],[
+ want_ige_mac_integration=yes
+])
+if test "x$want_ige_mac_integration" = "xno" -o "x$no_gtk" = "xyes" ; then
+ AC_MSG_RESULT(no)
+else
+ AC_MSG_RESULT(yes)
+ AC_WIRESHARK_IGE_MAC_INTEGRATION_CHECK
+fi
+
+
AC_SUBST(wireshark_bin)
AC_SUBST(wireshark_man)