aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJakub Zawadzki <darkjames-ws@darkjames.pl>2011-05-12 17:14:59 +0000
committerJakub Zawadzki <darkjames-ws@darkjames.pl>2011-05-12 17:14:59 +0000
commitb680407847c4b200f6e511073178b999527e9980 (patch)
tree0a3bd467eb38727259c4015b1f31be9bffb8ac3d /configure.in
parent21363344ec09df199680642fd3de227cefb7afb6 (diff)
Conditional support for packet-editor [default=no].
svn path=/trunk/; revision=37084
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 056a631515..00500ec785 100644
--- a/configure.in
+++ b/configure.in
@@ -718,6 +718,14 @@ AC_ARG_ENABLE(wireshark,
[build GTK+-based wireshark. @<:@default=yes, if GTK+ available@:>@]),
enable_wireshark=$enableval,enable_wireshark=yes)
+AC_ARG_ENABLE(packet-editor,
+ AC_HELP_STRING( [--enable-packet-editor],
+ [add support for packet editor in wireshark. @<:@default=no@:>@]),
+ enable_packet_editor=$enableval,enable_packet_editor=no)
+if test x$enable_packet_editor = xyes; then
+ AC_DEFINE(WANT_PACKET_EDITOR, 1, [Support for packet editor])
+fi
+
AC_ARG_ENABLE(threads,
AC_HELP_STRING( [--enable-threads],
[use threads in wireshark. @<:@default=no@:>@]),