aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2000-07-14 07:11:53 +0000
committerGuy Harris <guy@alum.mit.edu>2000-07-14 07:11:53 +0000
commita1b0b42431f2072ea589305792a0b0a47e75fc23 (patch)
treeec53f0668632038aef21ac9f30ff60714200aa0c /configure.in
parent9b652d0958e6297593c6346bfb2b75eb718e79a8 (diff)
Apparently, on systems with glibc 2.2, "inet_aton()" is declared in
<arpa/inet.h>, but is, in some fashion, declared differently from the way we declare it in "inet_v6defs.h", but "inet_ntop()" isn't defined, so we include "inet_v6defs.h" in "inet_pton.c", which causes "inet_pton.c" not to compile as we get a collision between the two declarations. Move the declaration of "inet_aton()" to "inet_aton.h", define "NEED_INET_ATON_H" iff we didn't find "inet_aton()" in the system libraries, and include "inet_aton.h" in the callers of "inet_aton()" iff "NEED_INET_ATON_H" is defined, so that it doesn't get declared by us if "inet_aton()" is defined by a system library (which hopefully means it's declared in <arpa/inet.h> instead). svn path=/trunk/; revision=2137
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index c17abb74c8..7f3a7bbc12 100644
--- a/configure.in
+++ b/configure.in
@@ -1,4 +1,4 @@
-# $Id: configure.in,v 1.94 2000/07/06 10:03:43 girlich Exp $
+# $Id: configure.in,v 1.95 2000/07/14 07:11:52 guy Exp $
dnl
dnl Process this file with autoconf 2.13 or later to produce a
dnl configure script; 2.12 doesn't generate a "configure" script that
@@ -313,6 +313,7 @@ AC_CHECK_FUNC(inet_aton, INET_ATON_O="",
if test "$ac_cv_func_inet_aton" = no ; then
INET_ATON_C="inet_aton.c"
INET_ATON_O="inet_aton.o"
+ AC_DEFINE(NEED_INET_ATON_H)
fi
AC_SUBST(INET_ATON_C)
AC_SUBST(INET_ATON_O)