aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2011-05-03 04:48:02 +0000
committerGuy Harris <guy@alum.mit.edu>2011-05-03 04:48:02 +0000
commit7eb472318477f4c1da066cb038fd197cb526e02a (patch)
tree886a71de7cdde51a6d1170586c46a0639f568778 /configure.in
parent89b6793472dd245ccf6a543e5005eaedf95daa5a (diff)
Don't bother checking for gzgets(), as we don't use it, and don't even
need to use its presence in zlib as a proxy for "not the crufty old zlib that comes with some versions of X11". Do, however, check for inflatePrime() there, instead, just in case the crufty old zlib that comes with some versions of X11 lack it; this is to prevent the configure script from assuming a shiny new zlib by testing with a non-X11 program, causing the build to fail when you build Wireshark. svn path=/trunk/; revision=36969
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 7 insertions, 10 deletions
diff --git a/configure.in b/configure.in
index 61e67d170a..056a631515 100644
--- a/configure.in
+++ b/configure.in
@@ -1235,11 +1235,11 @@ else
fi
dnl zlib check
-AC_MSG_CHECKING(whether to use zlib for reading compressed capture files)
+AC_MSG_CHECKING(whether to use zlib for gzip compression and decompression)
AC_ARG_WITH(zlib,
AC_HELP_STRING([--with-zlib@<:@=DIR@:>@],
- [use zlib (located in directory DIR, if supplied) to read compressed data. @<:@default=yes, if available@:>@]),
+ [use zlib (located in directory DIR, if supplied) for gzip compression and decompression . @<:@default=yes, if available@:>@]),
[
if test $withval = no
then
@@ -1264,17 +1264,14 @@ else
AC_MSG_RESULT(yes)
AC_WIRESHARK_ZLIB_CHECK
if test "x$want_zlib" = "xno" ; then
- AC_MSG_RESULT(zlib not found - disabling compressed capture file support)
+ AC_MSG_RESULT(zlib not found - disabling gzip compression and decompression)
+ else
+ if test "x$ac_cv_func_inflatePrime" = "xno" ; then
+ AC_MSG_RESULT(inflatePrime not found in zlib - disabling gzipped capture file support)
+ fi
fi
fi
-if test "x$want_zlib" != "xno" ; then
- AC_CHECK_LIB(z, inflatePrime,
- [
- AC_DEFINE(HAVE_INFLATEPRIME, 1, [Define if we have inflatePrime])
- ])
-fi
-
dnl pcre check
AC_MSG_CHECKING(whether to use libpcre for regular expressions in dfilters)