aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2003-10-10 10:12:18 +0000
committerGuy Harris <guy@alum.mit.edu>2003-10-10 10:12:18 +0000
commit6670a92e854c399b0cf5d1a123cbfe5522f0d2c6 (patch)
tree139f943b96d9da31cb111c724a2681030f111b2a /configure.in
parent645f294232de78cf222ff1ed1c6786eb1014c696 (diff)
From Brad Hards: fix two problems:
1. the --without-adns case wasn't handled correctly; 2. the reporting at the end of the configure didn't deal with the case were the configure check failed (as in my example, where I only had the libadns package installed, not libadns-devel) - it reported that ADNS would be used. svn path=/trunk/; revision=8663
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 7542789c82..05c8d07c07 100644
--- a/configure.in
+++ b/configure.in
@@ -1,4 +1,4 @@
-# $Id: configure.in,v 1.224 2003/10/10 03:00:09 guy Exp $
+# $Id: configure.in,v 1.225 2003/10/10 10:12:18 guy Exp $
dnl
dnl Process this file with autoconf 2.13 or later to produce a
dnl configure script; 2.12 doesn't generate a "configure" script that
@@ -634,7 +634,7 @@ AC_SUBST(SNMP_LIBS)
dnl ADNS Check
ADNS_LIBS=''
AC_MSG_CHECKING(whether to use the GNU ADNS library if available)
-if test "x$enable_adns" = "xno" ; then
+if test "x$with_adns" = "xno" ; then
AC_MSG_RESULT(no)
else
AC_MSG_RESULT(yes)
@@ -833,10 +833,10 @@ else
zlib_message="yes"
fi
-if test "x$want_adns" = "xno" ; then
- adns_message="no"
-else
+if test "x$have_good_adns" = "xyes" ; then
adns_message="yes"
+else
+ adns_message="no"
fi
if test "x$NETSNMPCONFIG" != "xno" -a "x$NETSNMPCONFIG" != "x" -a -x "$NETSNMPCONFIG" ; then