aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorStephen Fisher <steve@stephen-fisher.com>2011-02-11 20:21:32 +0000
committerStephen Fisher <steve@stephen-fisher.com>2011-02-11 20:21:32 +0000
commit5e5aa3c09eb57e1ec35d25b043bb195513dc1627 (patch)
tree90453c642fa152efa8195bede5bfb86addf5f07b /configure.in
parent1b2f2426e0534a86cc40c3583633b4c79debdec9 (diff)
Add a command line argument for the configure script of "--with-gtk3" to
attempt to compile against GTK+ 3.0 (which can be installed at the same time as GTK+ 2.0). Also place a copy of the autoconf macro for finding GTK+ 3.0 in the aclocal-fallback directory taken from the GTK+ 3.0 distribution. (Note: Wireshark won't finish compiling with GTK+ 3.0 yet...) svn path=/trunk/; revision=35918
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index c108ae31b4..e2272d490b 100644
--- a/configure.in
+++ b/configure.in
@@ -182,6 +182,12 @@ if test "x$with_gcrypt" = "xyes"; then
)
fi
+AC_ARG_WITH([gtk3],
+ AC_HELP_STRING( [--with-gtk3=@<:@yes/no@:>@],
+ [use GTK+ 3.0 instead of 2.0 @<:@default=no@:>@]),
+ with_gtk3="$withval", with_gtk="no")
+
+
# libsmi
# FIXME: currently the path argument to with-libsmi is being ignored
AX_LIBSMI
@@ -689,12 +695,22 @@ AC_DEFINE_UNQUOTED(DOC_DIR, "$docdir", [Directory for docs])
# programs to be built with GTK+.
#
if test "x$enable_wireshark" = "xyes"; then
+if test "x$with_gtk3" = "xyes"; then
+ AM_PATH_GTK_3_0(3.0.0,
+ [
+ CFLAGS="$CFLAGS $GTK_CFLAGS"
+ CXXFLAGS="$CXXFLAGS $GTK_CFLAGS"
+ AC_DEFINE(HAVE_GTK, 1, [Define to 1 if compiling with GTK])
+ ], GTK_OK=no, gthread)
+
+else
AM_PATH_GTK_2_0(2.4.0,
[
CFLAGS="$CFLAGS $GTK_CFLAGS"
CXXFLAGS="$CXXFLAGS $GTK_CFLAGS"
AC_DEFINE(HAVE_GTK, 1, [Define to 1 if compiling with GTK])
], GTK_OK=no, gthread)
+fi
else
GTK_OK=no
fi