aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2001-07-26 22:05:01 +0000
committerGuy Harris <guy@alum.mit.edu>2001-07-26 22:05:01 +0000
commit3322b11fc2062b2e1b50d8c94ab31d5680d442ef (patch)
treec2c9b30bd93d32ba39aad8e4215acfd9266bb827 /configure.in
parent120e9b393f77ee62e7a188d79d2d87c9ae75a5cc (diff)
Fix from Michael Tuexen: define PLUGIN_DIR as NULL if plugin support is
disabled, so that the code that passes it to a subroutine compiles (the subroutine doesn't use that argument if plugin support is disabled - and shouldn't do so). svn path=/trunk/; revision=3790
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 17bd04d56b..96e9665255 100644
--- a/configure.in
+++ b/configure.in
@@ -1,4 +1,4 @@
-# $Id: configure.in,v 1.134 2001/07/26 07:25:43 guy Exp $
+# $Id: configure.in,v 1.135 2001/07/26 22:05:01 guy Exp $
dnl
dnl Process this file with autoconf 2.13 or later to produce a
dnl configure script; 2.12 doesn't generate a "configure" script that
@@ -617,8 +617,10 @@ then
eval echo "$PLUGIN_DIR"
)`
AC_DEFINE_UNQUOTED(PLUGIN_DIR,"$PLUGIN_DIR", [Plugin installation directory])
- AC_SUBST(PLUGIN_DIR)
+else
+ AC_DEFINE(PLUGIN_DIR,NULL)
fi
+AC_SUBST(PLUGIN_DIR)
dnl libtool defs
AC_LIBTOOL_DLOPEN