aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2017-08-06 18:03:14 -0700
committerGuy Harris <guy@alum.mit.edu>2017-08-07 01:04:01 +0000
commitfde17d9ba0c2d12434b26f5f0cb158093acfbfcf (patch)
tree3f98503f92f8a0c1975bbb323f9b82b124ec6334 /configure.ac
parenta511b7159123704c5c6e488b96c4ff3311498423 (diff)
Separate the C-only and C-and-C++ extra compiler options.
Move -Wduplicated-branches, which is C-and-C++, above -Wbad-function-cast, which is C-only. This matches CMakeLists.txt. Change-Id: I7c60695252645524f80461575ce3e92572e0efa7 Reviewed-on: https://code.wireshark.org/review/22981 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 46904d88fc..6e4f8aafa7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -739,6 +739,10 @@ AC_ARG_ENABLE(extra-compiler-warnings,
# (about glib library not using Doxygen)
#
AC_WIRESHARK_COMPILER_FLAGS_CHECK(-Wdocumentation)
+ #
+ # Works only with GCC 7
+ #
+ AC_WIRESHARK_COMPILER_FLAGS_CHECK(-Wduplicated-branches)
#
# The following are C only, not C++
@@ -748,10 +752,6 @@ AC_ARG_ENABLE(extra-compiler-warnings,
# never enable this one with -Werror.
#
AC_WIRESHARK_COMPILER_FLAGS_CHECK(-Wbad-function-cast, C)
-
- # Works only with GCC 7
- AC_WIRESHARK_COMPILER_FLAGS_CHECK(-Wduplicated-branches)
-
fi
])