aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2016-10-18 10:16:39 +0200
committerJörg Mayer <jmayer@loplof.de>2016-10-19 20:35:31 +0000
commitd3995b5248e412dd1b00c06a3f54936326967e2d (patch)
treed4098395b21258ce4dc564916a364f3a4ba93496 /configure.ac
parent5ab49c623df23a5d19cffdc29f912dd1d2798ca9 (diff)
Disable GTK+ by default.
I suggested disabling GTK+ by default at Sharkfest EU and no one objected, hence this patch. Disable it by default in both Autotools and CMake. Make sure it's enabled for Debian packaging. The RPM packaging enables GTK3 explicitly so no change appears to be necessary there. Change-Id: If5daeaef4bb26cf60006bc8883be15b2cf6c6ae4 Reviewed-on: https://code.wireshark.org/review/18256 Reviewed-by: Peter Wu <peter@lekensteyn.nl> Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Jörg Mayer <jmayer@loplof.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 378477a1de..5a0cede700 100644
--- a/configure.ac
+++ b/configure.ac
@@ -256,14 +256,14 @@ AC_ARG_WITH([qt],
AC_ARG_WITH([gtk],
AC_HELP_STRING( [--with-gtk=@<:@yes/no/2/3@:>@],
- [use GTK+ @<:@default=yes, if available@:>@]),
+ [use GTK+ @<:@default=no@:>@]),
AS_CASE([$withval],
[yes], [with_gtk="3 2 fail"],
[no], [with_gtk="no"],
[3], [with_gtk="3 fail3"],
[2], [with_gtk="2 fail2"],
[AC_MSG_ERROR([--with-gtk must be one of yes/no/2/3])]),
- with_gtk="3 2")
+ with_gtk="no")
# GnuTLS
# Version 3.0 switched from LGPLv2.1+ to LGPLv3+, then switched back to