aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2016-04-07 19:00:19 +0100
committerJoão Valverde <j@v6e.pt>2016-04-07 18:03:31 +0000
commita90c5ef6e2223ecfb02932d9233403591e28aebc (patch)
tree0f88520ea8c705c1cb99526bc9b48eb7d693f11c /configure.ac
parent08e01a6aeb8752ace82fc02cd555ba9144975feb (diff)
Revert "Try to suppress a compiler feature that goes wrong."
This reverts commit ec075789e31942008eb8ad7faf35b7012778dac8. Change-Id: I6f84f01f2027f32d3727dd9d7d097d6d90e063c2 Reviewed-on: https://code.wireshark.org/review/14851 Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 0 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac
index 1dbe9fd6b9..87ea6e4632 100644
--- a/configure.ac
+++ b/configure.ac
@@ -882,22 +882,6 @@ AC_WIRESHARK_COMPILER_FLAGS_CHECK(-Wno-long-long)
AC_WIRESHARK_COMPILER_FLAGS_CHECK(-Wheader-guard)
AC_WIRESHARK_COMPILER_FLAGS_CHECK(-Wunused-const-variable)
#
-# Either the version of clang on the "clang code analysis" buildbot is
-# horribly broken, or the header files on that buildbot are horribly
-# broken, as the perfectly-legitimate statement
-#
-# if( strcmp(argv[i],"--")==0 ) dashdash = 1;
-#
-# is getting stoopid "array index 3 is past the end of the array (which
-# contains 3 elements)" complaints from the compiler.
-#
-# The macro for strcmp() in glibc(?) really seems to give C compilers
-# conniptions; I think I've seen crap from GCC as well with that macro.
-#
-# So, alas, suppress the compile-time array bounds checks.
-#
-AC_WIRESHARK_COMPILER_FLAGS_CHECK(-Wnoarray-bounds)
-#
# The following are C only, not C++
#
AC_WIRESHARK_COMPILER_FLAGS_CHECK(-Wc++-compat, C)