aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJeff Morriss <jeff.morriss.ws@gmail.com>2013-02-07 20:51:52 +0000
committerJeff Morriss <jeff.morriss.ws@gmail.com>2013-02-07 20:51:52 +0000
commit8a6b4d596dbf6904c69a67c688318343e0e5ea84 (patch)
tree7eed006f4b581512bc7c20bbe6a46c8c41b92152 /configure.ac
parent669e68dfded50f813464eeb3dc4e334578f85de5 (diff)
QPropertyAnimation is needed for Qt builds and isn't present until Qt 4.6.0.
Add a (crude) check for the Qt version, making 4.6.0 the minimum. The existing checks in configure.ac should be moved into into this new module. svn path=/trunk/; revision=47537
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 7 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 7f02551996..86e3662417 100644
--- a/configure.ac
+++ b/configure.ac
@@ -907,10 +907,10 @@ GTK2_MIN_VERSION=2.12.0
AC_SUBST(GTK2_MIN_VERSION)
GTK3_MIN_VERSION=3.0.0
AC_SUBST(GTK3_MIN_VERSION)
+QT_MIN_VERSION=4.6.0
+AC_SUBST(QT_MIN_VERSION)
# GTK+ and Qt checks; we require GTK+ $GTK2_MIN_VERSION or later or
-# GTK3_MIN_VERSION or later, and, for now, don't require any particular
-# version of Qt (except perhaps by implication, as older versions might not
-# support pkgconfig).
+# GTK3_MIN_VERSION or later or Qt $QT_MIN_VERSION or later.
#
# We only do those if we're going to be building Wireshark;
# otherwise, we don't have any GUI to build, so we don't use
@@ -974,6 +974,10 @@ if test "x$enable_wireshark" = "xyes"; then
],
AC_MSG_NOTICE([QtPrintSupport not found. Assuming Qt4]))
+ # Check for the minimum Qt version
+ # XXX the above checks should be moved into AM_PATH_QT.
+ AM_PATH_QT($QT_MIN_VERSION, , [AC_MSG_ERROR([Qt is not available])])
+
#
# We don't know whether we have GTK+, but we
# won't be using it, so it's as if we don't