aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJeff Morriss <jeff.morriss.ws@gmail.com>2012-12-20 20:52:26 +0000
committerJeff Morriss <jeff.morriss.ws@gmail.com>2012-12-20 20:52:26 +0000
commit550c36d042c63053389dce37eb0f6f54e04155a6 (patch)
treea3bd5919e6523e72aae9aa9cbdc5a340e53200fb /configure.ac
parent0ddce65214d2f162b389910d4cb74d664bed562d (diff)
32-bit Linux (at least from Redhat) has a host_cpu of i686 (not i386). Don't force 8-byte alignment on such systems.
svn path=/trunk/; revision=46641
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 9 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 4b550cc3b2..eecc665cba 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2031,13 +2031,15 @@ AC_SUBST(PLUGIN_LIBS)
# alignment (64-bit x86 will get 8-byte alignment from G_MEM_ALIGN anyway).
#
AC_MSG_CHECKING(whether we need memory allocations to be 8-byte aligned)
-if test x$host_cpu != xi386
-then
- AC_MSG_RESULT(yes)
- AC_DEFINE(NEED_8_BYTE_ALIGNMENT, 1, [Define if we need memory allocations to be 8-byte aligned])
-else
- AC_MSG_RESULT(no)
-fi
+case $host_cpu in
+ i386|i486|i586|i686)
+ AC_MSG_RESULT(no)
+ ;;
+ *)
+ AC_MSG_RESULT(yes)
+ AC_DEFINE(NEED_8_BYTE_ALIGNMENT, 1, [Define if we need memory allocations to be 8-byte aligned])
+ ;;
+esac
dnl libtool defs
#