aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2012-12-31 21:29:47 +0000
committerGerald Combs <gerald@wireshark.org>2012-12-31 21:29:47 +0000
commit4ecf61b0df0fafd0e5c7f138c6d244e487776171 (patch)
treefffb96b4e58abc2b203482daa7d1c2555f470d77 /configure.ac
parent37d19a12023567f65f2049400cd72255b8f2c9d2 (diff)
If we're linking with Qt pass a hint to automake that it needs to use c++
linking. svn path=/trunk/; revision=46878
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 42a4987a13..621f465330 100644
--- a/configure.ac
+++ b/configure.ac
@@ -994,6 +994,7 @@ fi
# 2.32.0: 24 Mar 2012
# 2.34.0: 24 Sep 2012
+have_wireshark_cpp="false"
if test "$have_gtk" = "no" ; then
#
# We don't have GTK+.
@@ -1007,6 +1008,8 @@ if test "$have_gtk" = "no" ; then
#
wireshark_bin="wireshark\$(EXEEXT)"
wireshark_ui_lib="ui/qt/libqtui.a"
+ # Give automake a hint that it needs to use c++ linking.
+ have_wireshark_cpp="true"
wireshark_man="wireshark.1"
wireshark_SUBDIRS="codecs ui/qt"
else
@@ -1046,7 +1049,7 @@ else
wireshark_bin="wireshark\$(EXEEXT)"
wireshark_ui_lib="ui/gtk/libgtkui.a"
wireshark_man="wireshark.1"
- wireshark_SUBDIRS="codecs ui/gtk"
+ wireshark_SUBDIRS="codecs ui/gtk"
# Don't use GLIB_CFLAGS
AM_PATH_GLIB_2_0(2.14.0, , AC_MSG_ERROR(GLib 2.14 or later distribution not found.), gthread gmodule)
@@ -1178,6 +1181,7 @@ fi
AC_SUBST(wireshark_bin)
AC_SUBST(wireshark_ui_lib)
AC_SUBST(wireshark_man)
+AM_CONDITIONAL(HAVE_WIRESHARK_CPP, test "$have_wireshark_cpp" = "true")
# Enable/disable tshark