aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorStephen Fisher <sfisher@sdf.org>2014-12-22 13:50:10 -0700
committerStephen Fisher <sfisher@sdf.org>2014-12-23 00:22:23 +0000
commit3d62d2c396aa016d97f788205978f4fdba2d4d4b (patch)
tree161f97d511c7449b0caf17ab87edef4b0280a573 /configure.ac
parent59b4ab53fcf08db3daa7461b463ca47e83e55079 (diff)
Move popcount() to an optionally built part of wsutil for systems that
provide their own popcount(). Change-Id: Ic26f3b50cf0bd2b4af0d42e9c27488ebbac1ab33 Reviewed-on: https://code.wireshark.org/review/5998 Petri-Dish: Stephen Fisher <sfisher@sdf.org> Reviewed-by: Stephen Fisher <sfisher@sdf.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8fa43242f2..86fb03f8f4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2750,6 +2750,14 @@ AC_CHECK_FUNC(strptime,
STRPTIME_LO="strptime.lo")
AC_SUBST(STRPTIME_LO)
+AC_CHECK_FUNC(popcount,
+ [
+ POPCOUNT_LO=""
+ AC_DEFINE(HAVE_POPCOUNT, 1, [Define if you have the popcount function.])
+ ],
+ POPCOUNT_LO="popcount.lo")
+AC_SUBST(POPCOUNT_LO)
+
AC_CHECK_FUNCS(getprotobynumber gethostbyname2)
AC_CHECK_FUNCS(issetugid)
AC_CHECK_FUNCS(mmap mprotect sysconf)