aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2017-10-25 22:59:19 +0100
committerJoão Valverde <j@v6e.pt>2017-10-29 00:14:40 +0000
commit18237cfd1513e10bc02599c263fbd855551da628 (patch)
tree4acc73b86127cde41b5c7fef73face803cb3bd60 /configure.ac
parent7dbc520d57b8567738a15f617a11d9b5b70f40a7 (diff)
configure: Display ssh_user_agent as a libssh sub-option
Change-Id: I19e38015d1395b021bc5169a6bf37fba0c5b1fe9 Reviewed-on: https://code.wireshark.org/review/24116 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 4 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 41bb5f68e0..e13496cf92 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2970,16 +2970,13 @@ fi
if test "x$have_good_libssh" = "xyes" ; then
libssh_message="yes"
+ if test "x$have_ssh_userauth_agent" = "xno" ; then
+ ssh_userauth_agent_message=" (without ssh_userauth_agent)"
+ fi
else
libssh_message="no"
fi
-if test "x$have_ssh_userauth_agent" = "xyes" ; then
- ssh_userauth_agent_message="yes"
-else
- ssh_userauth_agent_message="no"
-fi
-
if test "x$have_good_nghttp2" = "xyes" ; then
nghttp2_message="yes"
else
@@ -3053,8 +3050,7 @@ echo " Use SSL crypto library : $ssl_message"
echo " Use GnuTLS library : $tls_message"
echo " Use POSIX capabilities library : $libcap_message"
echo " Use GeoIP library : $geoip_message"
-echo " Use libssh library : $libssh_message"
-echo " Have ssh_userauth_agent : $ssh_userauth_agent_message"
+echo " Use libssh library : ${libssh_message}${ssh_userauth_agent_message}"
echo " Use nl library : $libnl_message"
echo " Use SBC codec library : $have_sbc"
echo " Use SpanDSP library : $have_spandsp"