aboutsummaryrefslogtreecommitdiffstats
path: root/asn1/t124/Makefile.am
diff options
context:
space:
mode:
authorJeff Morriss <jeff.morriss@ulticom.com>2011-10-10 02:31:11 +0000
committerJeff Morriss <jeff.morriss@ulticom.com>2011-10-10 02:31:11 +0000
commitcf012d27b10930edc93ca0e44d2a38e69200169f (patch)
tree0c80b13c452cecb6bab14694c1bebf8e49a740a5 /asn1/t124/Makefile.am
parent6142dd287bb03011ee572d01bcf903c81523fd0c (diff)
Build the ASN.1 dissectors directly into epan/dissectors (rather than building
them and then copying them over). The "all" target to builds these dissectors now (instead of "generate_files" and/or "copy_files"). asn2wrs's "-O" option now means "the dissector goes in this directory" (rather than "all output goes in this directory"); it also means that the "-s" (single output file) option is now required. Fix things up so that it's possible to build all of the ASN.1 dissectors in one shot. Fix building of conformance files when doing out-of-source-tree builds. Unfortunately "make all" in the asn1 directory always builds something--I think because of circular depedencies. svn path=/trunk/; revision=39333
Diffstat (limited to 'asn1/t124/Makefile.am')
-rw-r--r--asn1/t124/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/asn1/t124/Makefile.am b/asn1/t124/Makefile.am
index 462af31e88..33a94fe030 100644
--- a/asn1/t124/Makefile.am
+++ b/asn1/t124/Makefile.am
@@ -24,3 +24,5 @@ include ../Makefile.preinc
include Makefile.common
include ../Makefile.inc
+MCS-PROTOCOL.asn: ../t125/MCS-PROTOCOL.asn
+ cp $< $(srcdir)/$@