aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2000-01-15 09:46:28 +0000
committerGuy Harris <guy@alum.mit.edu>2000-01-15 09:46:28 +0000
commiteacc4cad718b395b2f3f6789dea215d4a4044e6d (patch)
treeab007de703959ee29e43532acb5beceab756a844 /Makefile.am
parent486e259d949f5f8147d34a08bf9c26e89fbc005e (diff)
Arrange that, on Solaris, we link with "-lkstat" if necessary when
linking with "-lsnmp". Link only Ethereal and Tethereal with "-lpcap"; don't link editcap, or any of the test programs that the configure script builds, with it (because that means you also have to arrange that those test programs be linked with @SOCKET_LIBS@ and @NSL_LIBS@) - i.e., don't add it to LIBS, add it to PCAP_LIBS, and use that only for programs that need it. svn path=/trunk/; revision=1484
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 946429e64c..95ba9f7e32 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,7 +1,7 @@
# Makefile.am
# Automake file for Ethereal
#
-# $Id: Makefile.am,v 1.153 2000/01/15 08:08:19 guy Exp $
+# $Id: Makefile.am,v 1.154 2000/01/15 09:46:27 guy Exp $
#
# Ethereal - Network traffic analyzer
# By Gerald Combs <gerald@zing.org>
@@ -289,9 +289,9 @@ ethereal_DEPENDENCIES = \
ethereal_LDADD = \
$(ethereal_optional_objects) \
$(ethereal_additional_libs) \
- @SNMP_A@ \
+ @SNMP_LIBS@ \
@LIBLTDL@ "-dlopen" self \
- "-dlopen" plugins/gryphon/gryphon.la @GTK_LIBS@
+ "-dlopen" plugins/gryphon/gryphon.la @PCAP_LIBS@ @GTK_LIBS@
ethereal_LDFLAGS = -export-dynamic
@@ -315,10 +315,10 @@ tethereal_DEPENDENCIES = \
tethereal_LDADD = wiretap/libwiretap.a \
$(ethereal_optional_objects) \
$(tethereal_additional_libs) \
- @SNMP_A@ \
+ @SNMP_LIBS@ \
@LIBLTDL@ "-dlopen" self \
"-dlopen" plugins/gryphon/gryphon.la @GLIB_LIBS@ -lm \
- @SOCKET_LIBS@ @NSL_LIBS@
+ @PCAP_LIBS@ @SOCKET_LIBS@ @NSL_LIBS@
tethereal_LDFLAGS = -export-dynamic