aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPeter Wu <peter@lekensteyn.nl>2016-03-27 23:31:36 +0200
committerPeter Wu <peter@lekensteyn.nl>2016-03-28 22:13:59 +0000
commite6c54017a7fbf4009454577a445530a7649f2c4f (patch)
treebff7bb32beecb8b9038feedeff1e500e8ce864be /Makefile.am
parent30900b443b85a7e760d703ca3d6efe61df4fe623 (diff)
Fix out-of-tree "gen-authors" target
Change directory to the source tree before invoking `git shortlog`, otherwise it fails on build directories outside the source tree. Alexis suggested to move the git invocation to the perl script, this is done now and also avoids writing AUTHORS.git in the source tree. Change-Id: I5905ebf40d8d32a586c88671b52f28c542ca33ba Reviewed-on: https://code.wireshark.org/review/14660 Reviewed-by: João Valverde <j@v6e.pt> Reviewed-by: Gerald Combs <gerald@wireshark.org> Reviewed-by: Peter Wu <peter@lekensteyn.nl>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 2 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 90eb45abec..c0d6f24395 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1071,7 +1071,6 @@ if HAVE_DOXYGEN
zip -rq wsar_html.zip wsar_html
endif
+# Update AUTHORS file with entries from git shortlog
gen-authors:
-#Generate list of AUTHORS (Name + E-Mail) sort by number of commit
- git --no-pager shortlog -se HEAD > $(top_srcdir)/AUTHORS.git
- $(PERL) $(top_srcdir)/tools/generate_authors.pl $(top_srcdir)/AUTHORS.src $(top_srcdir)/AUTHORS.git > $(top_srcdir)/AUTHORS
+ cd $(top_srcdir) && $(PERL) tools/generate_authors.pl AUTHORS.src > AUTHORS