aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJeff Morriss <jeff.morriss.ws@gmail.com>2014-12-04 09:54:08 -0500
committerJeff Morriss <jeff.morriss.ws@gmail.com>2014-12-04 14:56:40 +0000
commitab3c182f217b0d531b364cd2101f77970ebe29d7 (patch)
treef47034537bc13ead54469da8a8f6bb4ebc55bd3c /Makefile.am
parentb2fcbb2ba291e4c1110ef251d4349f94d1aa2bf4 (diff)
There's no need to talk about update-alternatives here.
Our "make install" process does nothing with 'alternatives'. Our RPMs do use alternatives but they do the necessary update-alternatives stuff already. (If someone wants to set up Linux "make install"s to use alternatives it would make sense to put these notes to the user back in.) Change-Id: Ib7f4655a222ccaee83830a97b213656856cee73e Reviewed-on: https://code.wireshark.org/review/5622 Reviewed-by: Jeff Morriss <jeff.morriss.ws@gmail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 0 insertions, 12 deletions
diff --git a/Makefile.am b/Makefile.am
index 22ca89e3fc..239964fb83 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1490,8 +1490,6 @@ uninstall-hook: update-databases-and-caches-uninstall
# We only need to run gtk-update-icon-cache if we're installing a GTK+
# version of Wireshark.
#
-# The update-alternatives suggestions need work.
-#
# We neither need nor want any of this on OS X, nor do we want it if
# we're not building Wireshark (that being the only desktop app).
#
@@ -1506,18 +1504,8 @@ endif
endif
update-databases-and-caches-install: update-databases-and-caches-common
-if BUILDING_WIRESHARK
-if NOT_OS_X
- @echo "You may need to run \"update-alternatives --install $(bindir)/wireshark wireshark $(bindir)/wireshark-qt 50\""
-endif
-endif
update-databases-and-caches-uninstall: update-databases-and-caches-common
-if BUILDING_WIRESHARK
-if NOT_OS_X
- @echo "You may need to run \"update-alternatives --remove wireshark $(bindir)/wireshark-qt\""
-endif
-endif
# Used by svr4-package and osx-package
# We load top_stagedir with an absolute path so that libtool doesn't freak.