aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2013-01-02 19:19:10 +0000
committerGerald Combs <gerald@wireshark.org>2013-01-02 19:19:10 +0000
commita50850c0cd9852ad0e3e675d473b2ce98e916d95 (patch)
treef3db98c23267f7f374111635d3d9f1d47f6ed852 /Makefile.am
parent6e77aef9466cfd320f2ab0ee3761c29db9c8ba98 (diff)
Fix UI library dependency checking.
svn path=/trunk/; revision=46902
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index b2e538280b..ff39135052 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -337,8 +337,14 @@ endif
# although it's also possible that -lgmodule is in GTK_LIBS but not
# GLIB_LIBS (that's the case on my machine right now, for example).
#
+if HAVE_Qt
+wireshark_ui_ldadd = ui/qt/libqtui.a
+else
+wireshark_ui_ldadd = ui/gtk/libgtkui.a
+endif
+
wireshark_LDADD = \
- @wireshark_ui_lib@ \
+ $(wireshark_ui_ldadd) \
ui/libui.a \
ui/libui_dirty.a \
codecs/libcodec.a \