aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJeff Morriss <jeff.morriss.ws@gmail.com>2012-12-19 02:09:48 +0000
committerJeff Morriss <jeff.morriss.ws@gmail.com>2012-12-19 02:09:48 +0000
commit8a916449e57b324b70999d21c8d5691f8e07695a (patch)
treeabd79394ab1a5f7a76ea740f3430092f88a66e2b /Makefile.am
parent3739c083bf6de622413e844f2c663a95cfdf895d (diff)
As suggested in https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=8076 :
Enable PIE (if the compiler supports it) when compiling dumpcap. Do this regardless of whether we're configured to install dumpcap setuid-root because some users will end up running dumpcap as root regardless of how we were configured. svn path=/trunk/; revision=46608
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 94a4d302ca..4fb1092f1e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -85,7 +85,7 @@ diameter_DATA = \
diameter/Vodafone.xml \
diameter/AlcatelLucent.xml \
diameter/Nokia.xml \
- diameter/NokiaSiemensNetworks.xml
+ diameter/NokiaSiemensNetworks.xml
#
# Install the DTDs directory files in the "dtds" subdirectory
@@ -503,7 +503,8 @@ dumpcap_LDADD = \
@SYSTEMCONFIGURATION_FRAMEWORKS@ \
@COREFOUNDATION_FRAMEWORKS@ \
@LIBCAP_LIBS@
-dumpcap_CFLAGS = $(AM_CLEAN_CFLAGS)
+dumpcap_CFLAGS = $(AM_CLEAN_CFLAGS) $(PIE_CFLAGS)
+dumpcap_LDFLAGS = $(PIE_LDFLAGS)
# Common headers
AM_CPPFLAGS = -I$(top_srcdir) -I$(top_srcdir)/wiretap \