aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>1999-08-04 04:37:46 +0000
committerGuy Harris <guy@alum.mit.edu>1999-08-04 04:37:46 +0000
commit47d1269da4591df45f5df31e33b275822734c5eb (patch)
tree36bdc95f2acc35c4802d9b5b3a2fb43235f3118d /Makefile.am
parent94f3a2c640c3ec15a58a50ef67f2cf1578934999 (diff)
Add a "dissect_xdlc_control()" routine, to dissect the control field of
SDLC-derived protocols such as HDLC and derivatives of it such as LAPB, IEEE 802.2 LLC, and so on. Have the LLC and LAPB dissectors use it. Make "dissect_numeric_bitfield()" put the low-order bit of the bitfield in the low-order bit of an integer when printing it, so that the right value is printed. svn path=/trunk/; revision=434
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index e1ff84f339..8fd0520865 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -103,11 +103,13 @@ ethereal_SOURCES = \
resolv.c \
resolv.h \
smb.h \
- timestamp.h \
- util.c \
summary.c \
summary.h \
- util.h
+ timestamp.h \
+ util.c \
+ util.h \
+ xdlc.c \
+ xdlc.h
EXTRA_ethereal_SOURCES = \
dfilter-grammar.c \