aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorGilbert Ramirez <gram@alumni.rice.edu>1999-03-28 18:32:03 +0000
committerGilbert Ramirez <gram@alumni.rice.edu>1999-03-28 18:32:03 +0000
commit2b86d46d706b3f60e3804b6ee9348752aa601b9a (patch)
tree73171006c6a2e830fe9b6742f081ab1e0b24131c /Makefile.am
parent4932ef3dcc5b76692e982fbb4d17153e998f69ba (diff)
Jun-ichiro's IPv6 patch is merged in with ethereal and now uses the new
proto*() functions. The configure script tries to use ipv6 name resolution if it knows the type of ipv6 stack the user has (this can be avoided with the --disable-ipv6 switch) Additionally, the configure script now deals with wiretap better. If the user doesn't want to compile wiretap, the wiretap is never visited. A few unnecessary #includes were removed from some wiretap files, and a CPP macro was moved from bpf.c to wtap.h. svn path=/trunk/; revision=229
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 9 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index 3c3baeaa66..07423d8a45 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -26,11 +26,13 @@ ethereal_SOURCES = \
packet-fddi.c \
packet-giop.c \
packet-http.c \
- packet-llc.c \
- packet-lpd.c \
packet-ip.c \
+ packet-icmpv6.c \
+ packet-ipsec.c \
packet-ipv6.c \
packet-ipx.c \
+ packet-llc.c \
+ packet-lpd.c \
packet-nbipx.c \
packet-nbns.c \
packet-ncp.c \
@@ -88,9 +90,10 @@ ps.c: print.ps rdps
rdps: rdps.c
$(CC) -o rdps rdps.c
-DISTCLEANFILES = \
- rdps \
- ps.c
+DISTCLEANFILES = \
+ rdps \
+ ps.c \
+ *~
EXTRA_DIST = \
doc/Makefile \
@@ -103,4 +106,4 @@ EXTRA_DIST = \
print.ps \
rdps.c
-SUBDIRS= wiretap
+SUBDIRS = @SUBDIRS@