aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2015-03-13 09:21:01 -0700
committerGerald Combs <gerald@wireshark.org>2015-03-13 22:41:40 +0000
commitf074647d2b6b16af34a2a9595adffd78c3a2dfe3 (patch)
tree89e929cb7e60a9dd4b9fe8dfa17a43f89b72fe73 /CMakeLists.txt
parent8f9e543d4ec168ba3f85bc37ba6236d08c910a53 (diff)
Add a test-programs target everywhere.
Add a "test-programs" target to each toolchain which builds each unit test executable. "test-programs" must now be built before running the unit test suite. Change-Id: I9317a1e305d987f244c4bd8b4a7f05d11fed7090 Reviewed-on: https://code.wireshark.org/review/7673 Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 12 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index dd37e34311..1f22126742 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2301,7 +2301,7 @@ else()
set(TEST_SH_BIN_DIR $<TARGET_FILE_DIR:epan>)
endif()
-add_custom_target(test-sh ALL
+add_custom_target(test-sh
COMMAND ${CMAKE_COMMAND}
-DCMAKE_MODULE_PATH=${CMAKE_MODULE_PATH}
-DTEST_SH_BIN_DIR=${TEST_SH_BIN_DIR}
@@ -2310,6 +2310,17 @@ add_custom_target(test-sh ALL
DEPENDS ${CMAKE_SOURCE_DIR}/cmake/modules/GenerateTestSh.cmake
)
+add_custom_target(test-programs
+ DEPENDS test-sh
+ exntest
+ oids_test
+ reassemble_test
+ tvbtest
+ wmem_test
+ COMMENT "Building unit test programs and wrapper"
+)
+
+
#
# Editor modelines - http://www.wireshark.org/tools/modelines.html
#